<!DOCTYPE html>
<!--[if IEMobile 7]><html class="no-js ie iem7" lang="en" dir="ltr"><![endif]-->
<!--[if lte IE 6]><html class="no-js ie lt-ie9 lt-ie8 lt-ie7" lang="en" dir="ltr"><![endif]-->
<!--[if (IE 7)&(!IEMobile)]><html class="no-js ie lt-ie9 lt-ie8" lang="en" dir="ltr"><![endif]-->
<!--[if IE 8]><html class="no-js ie lt-ie9" lang="en" dir="ltr"><![endif]-->
<!--[if (gte IE 9)|(gt IEMobile 7)]><html class="no-js ie" lang="en" dir="ltr" prefix="og: http://ogp.me/ns# article: http://ogp.me/ns/article# book: http://ogp.me/ns/book# profile: http://ogp.me/ns/profile# video: http://ogp.me/ns/video# product: http://ogp.me/ns/product#"><![endif]-->
<!--[if !IE]><!--><html class="no-js" lang="en" dir="ltr" prefix="og: http://ogp.me/ns# article: http://ogp.me/ns/article# book: http://ogp.me/ns/book# profile: http://ogp.me/ns/profile# video: http://ogp.me/ns/video# product: http://ogp.me/ns/product#"><!--<![endif]-->
<head>
<title>Blue Devils easily knock off top-ranked Hornell in season opener | The Batavian</title>
<!--[if IE]><![endif]-->
<meta charset="utf-8" />
<meta name="HandheldFriendly" content="true" />
<meta name="MobileOptimized" content="width" />
<link rel="shortcut icon" href="http://www.thebatavian.com/favicon.ico" type="image/vnd.microsoft.icon" />
<meta http-equiv="cleartype" content="on" />
<link rel="profile" href="http://www.w3.org/1999/xhtml/vocab" />
<link rel="apple-touch-icon" sizes="57x57" href="/files/favicons/apple-touch-icon-57x57.png" />
<link rel="apple-touch-icon" sizes="60x60" href="/files/favicons/apple-touch-icon-60x60.png" />
<link rel="apple-touch-icon" sizes="72x72" href="/files/favicons/apple-touch-icon-72x72.png" />
<link rel="apple-touch-icon" sizes="76x76" href="/files/favicons/apple-touch-icon-76x76.png" />
<link rel="apple-touch-icon" sizes="114x114" href="/files/favicons/apple-touch-icon-114x114.png" />
<link rel="apple-touch-icon" sizes="120x120" href="/files/favicons/apple-touch-icon-120x120.png" />
<link rel="apple-touch-icon" sizes="144x144" href="/files/favicons/apple-touch-icon-144x144.png" />
<link rel="apple-touch-icon" sizes="152x152" href="/files/favicons/apple-touch-icon-152x152.png" />
<link rel="apple-touch-icon" sizes="180x180" href="/files/favicons/apple-touch-icon-180x180.png" />
<link rel="icon" type="image/png" href="/files/favicons/favicon-32x32.png" sizes="32x32" />
<link rel="icon" type="image/png" href="/files/favicons/android-chrome-192x192.png" sizes="192x192" />
<link rel="icon" type="image/png" href="/files/favicons/favicon-96x96.png" sizes="96x96" />
<link rel="icon" type="image/png" href="/files/favicons/favicon-16x16.png" sizes="16x16" />
<link rel="manifest" href="/files/favicons/manifest.json" />
<meta name="msapplication-TileColor" content="#da532c" />
<meta name="msapplication-TileImage" content="/files/favicons/mstile-144x144.png" />
<meta name="theme-color" content="#ffffff" />
<script type="text/javascript" src="//cdn.broadstreetads.com/init.js"></script>
<meta name="description" content="The Batavia Blue Devils have a message for the rest of Section V Class B: We&#039;re coming for the block. They delivered that message loud and clear last night to #2 ranked Hornell (Batavia is ranked #1), the team that took the block (the Section V sectional trophy) from them in 2017, with a convincing 48-14 win at home. The Blue Devils relished the win against a perennial Class B" />
<meta name="keywords" content="football, sports, batavia, Batavia HS, news" />
<meta name="viewport" content="width=device-width" />
<meta name="generator" content="Drupal 7 (http://drupal.org)" />
<link rel="image_src" href="http://www.thebatavian.com/sites/all/modules/features/site_batavian/batavian.png" />
<link rel="canonical" href="http://www.thebatavian.com/howard-b-owens/blue-devils-easily-knock-off-top-ranked-hornell-in-season-opener/520826" />
<link rel="shortlink" href="http://www.thebatavian.com/node/520826" />
<meta property="og:site_name" content="The Batavian" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Blue Devils easily knock off top-ranked Hornell in season opener" />
<meta property="og:url" content="http://www.thebatavian.com/howard-b-owens/blue-devils-easily-knock-off-top-ranked-hornell-in-season-opener/520826" />
<meta property="og:description" content="The Batavia Blue Devils have a message for the rest of Section V Class B: We&#039;re coming for the block. They delivered that message loud and clear last night to #2 ranked Hornell (Batavia is ranked #1), the team that took the block (the Section V sectional trophy) from them in 2017, with a convincing 48-14 win at home. The Blue Devils relished the win against a perennial Class B rival and Southern Tier powerhouse. &quot;It means a lot,&quot; said senior QB Ethan Biscaro. &quot;To lose last year (in the Section V title game) and have them open up here at home, it couldn’t have been any better.&quot; The message the rest of the class might want to heed is the 2018 Blue Devils are more than their two-time All-Greater-Rochester star Ray Leach. This team has weapons in players like Biscaro, Alex Rood, and Cody Burns who can also chew up yards and put points on the board. Batavia had 379 total yards on the ground. Rood carried the ball 13 times for 168 yards and a TD. Burns had five carries for 95 yards and a TD. And Leach ran 14 times for 88 yards and two TDs. Biscaro was also 3-5 passing for 32 yards and a TD. Burns had the TD reception. Head coach Brennan Briggs can&#039;t deny he&#039;s excited by the talent on the team but he also pointed out, it&#039;s one game, it&#039;s early in the season, the team still has a lot to learn and improve on and if they don&#039;t improve every week they won&#039;t be able to handle the rigors of post-season play. &quot;I&#039;m never going to get complacent with where we are I can guarantee that,&quot; Briggs said. &quot;I&#039;ll be watching film tonight. I&#039;ll be watching it tomorrow morning. I&#039;ll be going down watching Lavonia a couple hours away tomorrow. So we&#039;ll we&#039;ll have his team ready to go next week and we&#039;ll fix our mistakes and hopefully get better every day.&quot; Briggs is never going to come into a game expecting his team to lose, even against a team like Hornell, but he did not predict a blow-out win. &quot;I still don&#039;t know if the score tells the true story,&quot; Briggs said. &quot;You know, as the season goes on we&#039;ll see. This is a great win. But you know it&#039;s going to be more important if we see them in the sectionals, sometime in the sectional tournament, to see if we play our best game against them.&quot; Rood and Leach, along with Briggs, gave all the credit to the offensive line for the team&#039;s dominant performance offensively. &quot;They did a fantastic job and we&#039;re tough on them,&quot; Briggs said. &quot;We&#039;re as tough on them as any of the positions on the team because we told them, &#039;hey you know you win or lose games up front.&#039; They take pride in it. They&#039;re a brotherhood.&quot; For Burns, a junior, this was a break-out game. At 5&#039;6&quot;, he&#039;s one of the smallest players on the field but he plays big. And he&#039;s fast. He scored his TD on a busted play where the offensive line pushed left and he ran right. By the time the Hornell defense realized it was following the line and not the ball, it was too late. Burns was gone. Nobody could catch him. He streaked more than 60 yards untouched for a TD. On defense, he started at linebacker. Yes, at 150 pounds, linebacker. &quot;On defense, he plays tough,&quot; Briggs said. &quot;He&#039;s not big at all but he&#039;ll bring it. He&#039;s ready to go bust the wedge on kickoff or knock their teeth in.&quot; This season was also a test for the home team. They had to show they could overcome off-season turmoil and focus on football. A month ago, Leach and teammate Antwan Odom got into a fight on Ross Street. Odom is accused of pulling out a pocket knife and stabbing Leach at least 10 times, leaving him with eight wounds that required stitches. Briggs said his players did a good job of keeping the off-field antics out of the locker room and off the practice field. &quot;Everybody really put it behind them,&quot; Briggs said. &quot;It&#039;s an unfortunate thing but you know we&#039;re here now and we&#039;re living in the moment and moving forward.&quot; Leach said he&#039;s feeling much better and came into the game ready for the season. &quot;I just had to stay positive and lean on my teammates,&quot; Leach said. &quot;My teammates picked me up and I just had to work hard and practice on whatever little things I can do.&quot; Also in Genesee County football on Friday:  Alexander beat York-Pavilion 50 to 12. Chris McClinic had 11 carries for 149 yards and 1 TD run and 1 kick return for TD. Terrez Smith rushed five times for 146 yards and three touchdowns. Ty Woods hauled in three passes for 64 yards and a TD. QB Dylan Busch was 6-7 for 81 yards and a TD. Jake Jasen had 19 tackles. He also rushed three times for 15 yards and TD late in the game. Geneseo beat Pembroke 30-9. Le Roy beat Avon 47-13. Le Roy&#039;s offense rolled up 413 total yards. Cineque Robinson had 11 carries for 113 yards and a touchdown, Jake Hill had eight rushes for 93 yards and two TDs, Kyler LaCarte picked up 62 yards on 13 touches and scored twice. Hill was 5-10 passing for 60 yards and TD. Anthony Leitte led the team with seven tackles. Top Photo: Biscaro (#8) and Burns (#12) celebrate after Burns scored a TD on a busted play. Alex Rood Biscaro scores. Leach just about to cross the goal line on the second of his two TDs. Rood with a tackle in the backfield. He had eight tackles to lead the team Friday. Rood breaks away for another TD. Burns To purchase prints for photos, click here." />
<meta property="og:updated_time" content="2018-09-01T13:20:21-04:00" />
<meta property="og:image" content="http://www.thebatavian.com/sites/all/modules/features/site_batavian/batavian.png" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:site" content="@thebatavian" />
<meta name="twitter:creator" content="@thebatavian" />
<meta name="twitter:title" content="Blue Devils easily knock off top-ranked Hornell in season opener" />
<meta name="twitter:url" content="http://www.thebatavian.com/howard-b-owens/blue-devils-easily-knock-off-top-ranked-hornell-in-season-opener/520826" />
<meta name="twitter:description" content="The Batavia Blue Devils have a message for the rest of Section V Class B: We&#039;re coming for the block. They delivered that message loud and clear last night to #2 ranked Hornell (Batavia is ranked" />
<meta name="twitter:image" content="http://www.thebatavian.com/sites/all/modules/features/site_batavian/batavian.png" />
<meta property="article:publisher" content="https://www.facebook.com/thebatavian" />
<meta property="article:tag" content="football" />
<meta property="article:tag" content="sports" />
<meta property="article:tag" content="batavia" />
<meta property="article:tag" content="Batavia HS" />
<meta property="article:tag" content="news" />
<meta property="article:published_time" content="2018-09-01T13:15:37-04:00" />
<meta property="article:modified_time" content="2018-09-01T13:20:21-04:00" />
<meta name="dcterms.title" content="Blue Devils easily knock off top-ranked Hornell in season opener" />
<meta name="dcterms.creator" content="Howard B. Owens" />
<meta name="dcterms.description" content="The Batavia Blue Devils have a message for the rest of Section V Class B: We&#039;re coming for the block. They delivered that message loud and clear last night to #2 ranked Hornell (Batavia is ranked #1), the team that took the block (the Section V sectional trophy) from them in 2017, with a convincing 48-14 win at home. The Blue Devils relished the win against a perennial Class B rival and Southern Tier powerhouse. &quot;It means a lot,&quot; said senior QB Ethan Biscaro. &quot;To lose last year (in the Section V title game) and have them open up here at home, it couldn’t have been any better.&quot; The message the rest of the class might want to heed is the 2018 Blue Devils are more than their two-time All-Greater-Rochester star Ray Leach. This team has weapons in players like Biscaro, Alex Rood, and Cody Burns who can also chew up yards and put points on the board. Batavia had 379 total yards on the ground. Rood carried the ball 13 times for 168 yards and a TD. Burns had five carries for 95 yards and a TD. And Leach ran 14 times for 88 yards and two TDs. Biscaro was also 3-5 passing for 32 yards and a TD. Burns had the TD reception. Head coach Brennan Briggs can&#039;t deny he&#039;s excited by the talent on the team but he also pointed out, it&#039;s one game, it&#039;s early in the season, the team still has a lot to learn and improve on and if they don&#039;t improve every week they won&#039;t be able to handle the rigors of post-season play. &quot;I&#039;m never going to get complacent with where we are I can guarantee that,&quot; Briggs said. &quot;I&#039;ll be watching film tonight. I&#039;ll be watching it tomorrow morning. I&#039;ll be going down watching Lavonia a couple hours away tomorrow. So we&#039;ll we&#039;ll have his team ready to go next week and we&#039;ll fix our mistakes and hopefully get better every day.&quot; Briggs is never going to come into a game expecting his team to lose, even against a team like Hornell, but he did not predict a blow-out win. &quot;I still don&#039;t know if the score tells the true story,&quot; Briggs said. &quot;You know, as the season goes on we&#039;ll see. This is a great win. But you know it&#039;s going to be more important if we see them in the sectionals, sometime in the sectional tournament, to see if we play our best game against them.&quot; Rood and Leach, along with Briggs, gave all the credit to the offensive line for the team&#039;s dominant performance offensively. &quot;They did a fantastic job and we&#039;re tough on them,&quot; Briggs said. &quot;We&#039;re as tough on them as any of the positions on the team because we told them, &#039;hey you know you win or lose games up front.&#039; They take pride in it. They&#039;re a brotherhood.&quot; For Burns, a junior, this was a break-out game. At 5&#039;6&quot;, he&#039;s one of the smallest players on the field but he plays big. And he&#039;s fast. He scored his TD on a busted play where the offensive line pushed left and he ran right. By the time the Hornell defense realized it was following the line and not the ball, it was too late. Burns was gone. Nobody could catch him. He streaked more than 60 yards untouched for a TD. On defense, he started at linebacker. Yes, at 150 pounds, linebacker. &quot;On defense, he plays tough,&quot; Briggs said. &quot;He&#039;s not big at all but he&#039;ll bring it. He&#039;s ready to go bust the wedge on kickoff or knock their teeth in.&quot; This season was also a test for the home team. They had to show they could overcome off-season turmoil and focus on football. A month ago, Leach and teammate Antwan Odom got into a fight on Ross Street. Odom is accused of pulling out a pocket knife and stabbing Leach at least 10 times, leaving him with eight wounds that required stitches. Briggs said his players did a good job of keeping the off-field antics out of the locker room and off the practice field. &quot;Everybody really put it behind them,&quot; Briggs said. &quot;It&#039;s an unfortunate thing but you know we&#039;re here now and we&#039;re living in the moment and moving forward.&quot; Leach said he&#039;s feeling much better and came into the game ready for the season. &quot;I just had to stay positive and lean on my teammates,&quot; Leach said. &quot;My teammates picked me up and I just had to work hard and practice on whatever little things I can do.&quot; Also in Genesee County football on Friday:  Alexander beat York-Pavilion 50 to 12. Chris McClinic had 11 carries for 149 yards and 1 TD run and 1 kick return for TD. Terrez Smith rushed five times for 146 yards and three touchdowns. Ty Woods hauled in three passes for 64 yards and a TD. QB Dylan Busch was 6-7 for 81 yards and a TD. Jake Jasen had 19 tackles. He also rushed three times for 15 yards and TD late in the game. Geneseo beat Pembroke 30-9. Le Roy beat Avon 47-13. Le Roy&#039;s offense rolled up 413 total yards. Cineque Robinson had 11 carries for 113 yards and a touchdown, Jake Hill had eight rushes for 93 yards and two TDs, Kyler LaCarte picked up 62 yards on 13 touches and scored twice. Hill was 5-10 passing for 60 yards and TD. Anthony Leitte led the team with seven tackles. Top Photo: Biscaro (#8) and Burns (#12) celebrate after Burns scored a TD on a busted play. Alex Rood Biscaro scores. Leach just about to cross the goal line on the second of his two TDs. Rood with a tackle in the backfield. He had eight tackles to lead the team Friday. Rood breaks away for another TD. Burns To purchase prints for photos, click here." />
<meta name="dcterms.date" content="2018-09-01T13:15-04:00" />
<meta name="dcterms.type" content="Text" />
<meta name="dcterms.format" content="text/html" />
<meta name="dcterms.identifier" content="http://www.thebatavian.com/howard-b-owens/blue-devils-easily-knock-off-top-ranked-hornell-in-season-opener/520826" />
<link type="text/css" rel="stylesheet" href="/files/advagg_css/css__XXbyeB308d6UNZM5KuLGbg2bPON4J5k8ptcCm0wPsfU__grLySpTG81DPj20KaJSo_qpXTaKlSyusfIjll0kVbBg__utXHTkFnUKRmf6-l2oJ--4sEOpCnEq30N9WhiEympKQ.css" media="all" />
<link type="text/css" rel="stylesheet" href="/files/advagg_css/css__UqcW5aRBpyv9mYp--Lb4XPcG9siu5UGE9sNupJU1n5E__6o0ydCxaNIGzPuXPI-RyurJEY7DGATLQpxmMTxL860w__utXHTkFnUKRmf6-l2oJ--4sEOpCnEq30N9WhiEympKQ.css" media="print" />
<!--[if lte IE 8]>
<link type="text/css" rel="stylesheet" href="/files/advagg_css/css__1-jkVT27AjTIEc7RQZ_tNMScVUqhP653iLGt9cb3hvA__jKD8mglbQcCyrWksQ1n7K3i8wADBLFJj4_x5dau7PI8__utXHTkFnUKRmf6-l2oJ--4sEOpCnEq30N9WhiEympKQ.css" media="all" />
<![endif]-->
<script type="text/javascript" src="/files/advagg_js/js__x_vIaSvSxVq9YS7swvBviD7VGNa9ahBTuI9ZmlcZukU__lP3sLxjfxBvPEK_JfDM93M2Inp5t6cEMlVdgEY3cL7A__utXHTkFnUKRmf6-l2oJ--4sEOpCnEq30N9WhiEympKQ.js"></script>
<!--[if (gte IE 6)&(lte IE 8)]>
<script type="text/javascript" src="/files/advagg_js/js__ZUioMY4Endyj2YQ4nhQ0Oc7LQkgBC0vXfP9Pk1q-CYU__vFC-mxdyFZP7cYtMjHj1-wjzi8j929dCXx0NxwDhNbA__utXHTkFnUKRmf6-l2oJ--4sEOpCnEq30N9WhiEympKQ.js"></script>
<![endif]-->
<script type="text/javascript" src="/files/advagg_js/js__KaZp60twaRFpB7IdN57N22C_sjMQDY1aEnvERtknlIg__RPUH1Pa_09kAZ8D2-aMQ-HwAGT4k3LEND1qRE2SEZHM__utXHTkFnUKRmf6-l2oJ--4sEOpCnEq30N9WhiEympKQ.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
(function(i,s,o,g,r,a,m){i["GoogleAnalyticsObject"]=r;i[r]=i[r]||function(){(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)})(window,document,"script","http://www.thebatavian.com/files/googleanalytics/analytics.js?pblkc2","ga");ga("create", "UA-1245005-9", {"cookieDomain":"auto"});ga("send", "pageview");
//--><!]]>
</script>
<script type="text/javascript" src="/files/advagg_js/js__8aLlGN1wvu_U9q5Q8sjhNAv9uU9WJbFsy4eY2UiiMX4__mC1iziYJXMaVhorZpjtwQgvJUWTCH2JmJhseU41zkcg__utXHTkFnUKRmf6-l2oJ--4sEOpCnEq30N9WhiEympKQ.js"></script>
<script type="text/javascript" src="/files/advagg_js/js__vmsk2NZ9an7JwKYuWuh4cFlpjtJIcycN_A2bgtLiTBw__UYc99APq6SyLnIeP-qNzcTLSTrMLBpUHezdJ6xTpow8__utXHTkFnUKRmf6-l2oJ--4sEOpCnEq30N9WhiEympKQ.js"></script>
<script type="text/javascript">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</script>
</head>
<body class="html not-front not-logged-in page-node page-node- page-node-520826 node-type-blog node-promoted page-display-default section-howard-b-owens">
<div class="panel-display page-layout-threecol clear-block">
<div class="panel-panel panel-col-page-prefix clearfix">
<div class="inside clearfix"><div class="panel-pane pane-ad pane-1243 broadstreet-ad broadstreet-1243">
<script type="text/javascript">if (typeof broadstreet !== 'undefined') broadstreet.zone(1243);</script>
</div>
<div class="panel-pane pane-ad pane-1264 broadstreet-ad broadstreet-1264">
<script type="text/javascript">if (typeof broadstreet !== 'undefined') broadstreet.zone(1264);</script>
</div>
</div>
</div>
<div class="page-wrapper">
<header>
<div class="panel-panel panel-col-header-prefix clearfix">
<div class="inside"><div class="panel-pane pane-block pane-menu-secondary-menu">
<ul class="menu"><li class="first leaf"><a href="http://www.thebatavian.com/bowling" title="">Pin Points</a></li>
<li class="leaf"><a href="http://bataviaslist.com/e-mail-newsletter/" title="">E-mail Newsletter</a></li>
<li class="leaf"><a href="http://bataviaslist.com/calendar/" title="">Calendar</a></li>
<li class="leaf"><a href="/36453/contact-us" title="Contact Us">Contact Us</a></li>
<li class="leaf"><a href="http://mediakit.thebatavian.com/" title="Page about advertising on the site.">Advertise</a></li>
<li class="last leaf"><a href="/1917/about-batavian" title="">About</a></li>
</ul> </div>
</div>
</div>
<div class="panel-panel panel-col-header clearfix">
<div class="inside"><div class="panel-pane pane-page-logo">
<a href="/" rel="home" id="logo" title="Home"><img src="http://www.thebatavian.com/files/thebatavian_logo.png" alt="Home" /></a> </div>
<div class="panel-pane pane-search-api-page-search-box">
<form class="search-api-page-search-form-content" action="/howard-b-owens/blue-devils-easily-knock-off-top-ranked-hornell-in-season-opener/520826" method="post" id="search-api-page-search-form-content" accept-charset="UTF-8"><div><div class="form-item form-type-textfield form-item-keys-1">
<label class="element-invisible" for="edit-keys-1">Enter your keywords </label>
<input placeholder="Enter your keywords" type="text" id="edit-keys-1" name="keys_1" value="" size="15" maxlength="128" class="form-text" />
</div>
<input type="hidden" name="id" value="1" />
<input type="submit" id="edit-submit-1" name="op" value="Search" class="form-submit" /><input type="hidden" name="form_build_id" value="form-6MQ5jdt_cMGVXYhIHX6Jg62omG8Uzf2UcRuncleEu0w" />
<input type="hidden" name="form_id" value="search_api_page_search_form_content" />
</div></form> </div>
<div class="panel-pane pane-page-slogan">
Local Matters </div>
</div>
</div>
<div class="panel-panel panel-col-header-suffix clearfix">
<div class="inside"><div class="panel-pane pane-ad pane-1246 broadstreet-ad broadstreet-1246">
<script type="text/javascript">if (typeof broadstreet !== 'undefined') broadstreet.zone(1246);</script>
</div>
<div class="panel-pane pane-ad pane-1263 broadstreet-ad broadstreet-1263">
<script type="text/javascript">if (typeof broadstreet !== 'undefined') broadstreet.zone(1263);</script>
</div>
<div class="panel-pane pane-ad pane-1261 broadstreet-ad broadstreet-1261">
<script type="text/javascript">if (typeof broadstreet !== 'undefined') broadstreet.zone(1261);</script>
</div>
</div>
</div>
</header>
<div class="panel-panel panel-col-navigation clearfix">
<div class="inside"><div class="panel-pane pane-block pane-system-main-menu">
<ul class="menu"><li class="first leaf"><a href="/" title="">Home</a></li>
<li class="leaf"><a href="http://bataviaslist.com/" title="">Batavia&#039;s List</a></li>
<li class="leaf"><a href="http://shoplocal.thebatavian.com" title="">Shop Local</a></li>
<li class="leaf"><a href="/sports" title="Sports">Sports</a></li>
<li class="leaf"><a href="/business" title="News of local business">Business</a></li>
<li class="leaf"><a href="/announcements" title="">Announcements</a></li>
<li class="leaf"><a href="/obituaries" title="">Obituaries</a></li>
<li class="leaf"><a href="http://thebatavian.com/milestones" title="">Milestones</a></li>
<li class="leaf"><a href="http://bataviaslist.com/listings/browse-categories/9/employment/" title="">Jobs</a></li>
<li class="last leaf"><a href="http://bataviaslist.com/listings/browse-categories/4/real-estate-and-housing/" title="">Housing</a></li>
</ul> </div>
</div>
</div>
<div class="center-wrapper clearfix">
<div class="panel-panel page-col-first">
<div class="inside"><div class="panel-pane pane-ad pane-1248 broadstreet-ad broadstreet-1248">
<script type="text/javascript">if (typeof broadstreet !== 'undefined') broadstreet.zone(1248);</script>
</div>
<div class="panel-pane pane-ad pane-39917 broadstreet-ad broadstreet-39917">
<script type="text/javascript">if (typeof broadstreet !== 'undefined') broadstreet.zone(39917);</script>
</div>
<div class="panel-pane pane-custom pane-1">
<p>&gt;&gt; Download &lt;&lt;<br /><a href="https://itunes.apple.com/us/app/the-batavian/id1232469082?mt=8&amp;ign-mpt=uo%3D4" target="_blank">New iOS App</a><br /><a href="https://play.google.com/store/apps/details?id=com.thebatavian.mobile.thebatavian" target="_blank">New Android App</a></p>
</div>
<div class="panel-pane pane-block pane-user-login">
<h2 class="pane-title">User login</h2>
<form class="user-login-form" action="/" method="post" id="user-login-form" accept-charset="UTF-8"><div><div class="form-item form-type-textfield form-item-name">
<label for="edit-name">E-mail or username <span class="form-required" title="This field is required.">*</span></label>
<input type="text" id="edit-name" name="name" value="" size="15" maxlength="60" class="form-text required" />
</div>
<div class="form-item form-type-password form-item-pass">
<label for="edit-pass">Password <span class="form-required" title="This field is required.">*</span></label>
<input type="password" id="edit-pass" name="pass" size="15" maxlength="128" class="form-text required" />
</div>
<ul><li><a href="/user/register" title="Create a new user account.">Create new account</a></li>
<li><a href="/user/password" title="Request new password via e-mail.">Request new password</a></li>
</ul><input type="hidden" name="form_build_id" value="form-78MYNsTsLMm8su3IonhCvQVIK8iXj-XVBiYGA3as6zY" />
<input type="hidden" name="form_id" value="user_login_block" />
<div class="form-actions form-wrapper" id="edit-actions"><input type="submit" id="edit-submit" name="op" value="Log in" class="form-submit" /></div></div></form> </div>
<div class="panel-pane pane-ad pane-1255 broadstreet-ad broadstreet-1255">
<script type="text/javascript">if (typeof broadstreet !== 'undefined') broadstreet.zone(1255);</script>
</div>
<div class="panel-pane pane-block pane-menu-menu-genseecountytowns">
<h2 class="pane-title">Our Towns</h2>
<ul class="menu"><li class="first leaf"><a href="/alabama" title="">Alabama</a></li>
<li class="leaf"><a href="/alexander" title="">Alexander</a></li>
<li class="leaf"><a href="/batavia" title="">Batavia</a></li>
<li class="leaf"><a href="http://thebatavian.com/bergen" title="">Bergen</a></li>
<li class="leaf"><a href="/bethany" title="">Bethany</a></li>
<li class="leaf"><a href="/byron" title="">Byron</a></li>
<li class="leaf"><a href="http://thebatavian.com/corfu" title="">Corfu</a></li>
<li class="leaf"><a href="/darien" title="">Darien</a></li>
<li class="leaf"><a href="/elba" title="">Elba</a></li>
<li class="leaf"><a href="/tags/le-roy-1" title="">LeRoy</a></li>
<li class="leaf"><a href="/oakfield" title="">Oakfield</a></li>
<li class="leaf"><a href="/pavilion" title="">Pavilion</a></li>
<li class="leaf"><a href="/pembroke" title="">Pembroke</a></li>
<li class="last leaf"><a href="/stafford" title="">Stafford</a></li>
</ul> </div>
<div class="panel-pane pane-ad pane-1267 broadstreet-ad broadstreet-1267">
<script type="text/javascript">if (typeof broadstreet !== 'undefined') broadstreet.zone(1267);</script>
</div>
<div class="panel-pane pane-block pane-broadstreet-ads-53093">
<script type="text/javascript">if (typeof broadstreet !== 'undefined') broadstreet.zone(53093);</script>
</div>
<div class="panel-pane pane-ad pane-1253 broadstreet-ad broadstreet-1253">
<script type="text/javascript">if (typeof broadstreet !== 'undefined') broadstreet.zone(1253);</script>
</div>
<div class="panel-pane pane-ad pane-1266 broadstreet-ad broadstreet-1266">
<script type="text/javascript">if (typeof broadstreet !== 'undefined') broadstreet.zone(1266);</script>
</div>
<div class="panel-pane pane-ad pane-23893 broadstreet-ad broadstreet-23893">
<script type="text/javascript">if (typeof broadstreet !== 'undefined') broadstreet.zone(23893);</script>
</div>
<div class="panel-pane pane-views pane-comments-all-recent">
<h2 class="pane-title">Recent comments</h2>
<div class="view view-comments-all-recent view-id-comments_all_recent view-display-id-default view-dom-id-25cd73c199d5e00469ade06da2d0a9c7">
<div class="view-content">
<div class="item-list"><ul> <li class="views-row views-row-1 views-row-odd views-row-first">
<div class="views-field views-field-subject"> <span class="field-content"><a href="/comment/100561#comment-100561">Seems your IQ is lacking. Too</a></span> </div>
<div class="views-field views-field-name-1"> <span class="views-label views-label-name-1">by: </span> <span class="field-content"><span class="username">Daniel Norstrand</span></span> </div></li>
<li class="views-row views-row-2 views-row-even">
<div class="views-field views-field-subject"> <span class="field-content"><a href="/comment/100560#comment-100560">Too much crazy there for me</a></span> </div>
<div class="views-field views-field-name-1"> <span class="views-label views-label-name-1">by: </span> <span class="field-content"><span class="username">Howard B. Owens</span></span> </div></li>
<li class="views-row views-row-3 views-row-odd">
<div class="views-field views-field-subject"> <span class="field-content"><a href="/comment/100559#comment-100559">I&#039;d say your more likely the</a></span> </div>
<div class="views-field views-field-name-1"> <span class="views-label views-label-name-1">by: </span> <span class="field-content"><span class="username">Daniel Norstrand</span></span> </div></li>
<li class="views-row views-row-4 views-row-even">
<div class="views-field views-field-subject"> <span class="field-content"><a href="/comment/100558#comment-100558">Daniel - I thought your</a></span> </div>
<div class="views-field views-field-name-1"> <span class="views-label views-label-name-1">by: </span> <span class="field-content"><span class="username">Tim Miller</span></span> </div></li>
<li class="views-row views-row-5 views-row-odd">
<div class="views-field views-field-subject"> <span class="field-content"><a href="/comment/100557#comment-100557">A lot of nonsense there to</a></span> </div>
<div class="views-field views-field-name-1"> <span class="views-label views-label-name-1">by: </span> <span class="field-content"><span class="username">Howard B. Owens</span></span> </div></li>
<li class="views-row views-row-6 views-row-even">
<div class="views-field views-field-subject"> <span class="field-content"><a href="/comment/100556#comment-100556">And by the way, please don&#039;t</a></span> </div>
<div class="views-field views-field-name-1"> <span class="views-label views-label-name-1">by: </span> <span class="field-content"><span class="username">Daniel Norstrand</span></span> </div></li>
<li class="views-row views-row-7 views-row-odd">
<div class="views-field views-field-subject"> <span class="field-content"><a href="/comment/100554#comment-100554">Shimmer has been doing the </a></span> </div>
<div class="views-field views-field-name-1"> <span class="views-label views-label-name-1">by: </span> <span class="field-content"><span class="username">Daniel Norstrand</span></span> </div></li>
<li class="views-row views-row-8 views-row-even">
<div class="views-field views-field-subject"> <span class="field-content"><a href="/comment/100555#comment-100555">That sign is the only thing</a></span> </div>
<div class="views-field views-field-name-1"> <span class="views-label views-label-name-1">by: </span> <span class="field-content"><span class="username">John Roach</span></span> </div></li>
<li class="views-row views-row-9 views-row-odd">
<div class="views-field views-field-subject"> <span class="field-content"><a href="/comment/100553#comment-100553">Yes, there are issues to fix</a></span> </div>
<div class="views-field views-field-name-1"> <span class="views-label views-label-name-1">by: </span> <span class="field-content"><span class="username">Howard B. Owens</span></span> </div></li>
<li class="views-row views-row-10 views-row-even views-row-last">
<div class="views-field views-field-subject"> <span class="field-content"><a href="/comment/100552#comment-100552">David. I doubt it.</a></span> </div>
<div class="views-field views-field-name-1"> <span class="views-label views-label-name-1">by: </span> <span class="field-content"><span class="username">Ed Hartgrove</span></span> </div></li>
</ul></div> </div>
</div> </div>
<div class="panel-pane pane-ad pane-1252 broadstreet-ad broadstreet-1252">
<script type="text/javascript">if (typeof broadstreet !== 'undefined') broadstreet.zone(1252);</script>
</div>
<div class="panel-pane pane-ad pane-1265 broadstreet-ad broadstreet-1265">
<script type="text/javascript">if (typeof broadstreet !== 'undefined') broadstreet.zone(1265);</script>
</div>
<div class="panel-pane pane-ad pane-1250 broadstreet-ad broadstreet-1250">
<script type="text/javascript">if (typeof broadstreet !== 'undefined') broadstreet.zone(1250);</script>
</div>
<div class="panel-pane pane-block pane-menu-menu-sponsors">
<h2 class="pane-title">Community Sponsors</h2>
<ul class="menu"><li class="first leaf"><a href="http://www.adammillertoyandbicycle.com/" target="_blank">Adam Miller Toy and Bicycle</a></li>
<li class="leaf"><span title="" class="nolink">Advanced Podiatry Associates</span></li>
<li class="leaf"><a href="https://www.facebook.com/Affordable-Floorcovering-433392136828252/?fref=ts" title="">Affordable Floorcovering</a></li>
<li class="leaf"><a href="http://www.alexsribs.com/">Alex&#039;s Place</a></li>
<li class="leaf"><a href="https://www.facebook.com/AAYSD/" title="">All About You&#039;sd</a></li>
<li class="leaf"><a href="http://ascensionrcc.weconnect.com" title="">Ascension Parish</a></li>
<li class="leaf"><a href="http://www.autowashcarwash.com" title="">Auto Wash</a></li>
<li class="leaf"><a href="https://www.facebook.com/Assembly-of-God-Batavia-NY-193451590681411/" title="">Batavia Assembly of God Church</a></li>
<li class="leaf"><a href="http://www.bataviacc.com" title="">Batavia Country Club</a></li>
<li class="leaf"><a href="http://www.bataviadownscasino.com/">Batavia Downs</a></li>
<li class="leaf"><span title="" class="nolink">Batavia Optical</span></li>
<li class="leaf"><a href="https://www.facebook.com/BataviasOriginal/" title="">Batavia&#039;s Original</a></li>
<li class="leaf"><a href="http://www.bataviaplayers.org" title="">Batavia Players</a></li>
<li class="leaf"><span title="" class="nolink">Batavia Redemption Center, Eastown Beverages</span></li>
<li class="leaf"><a href="http://www.bataviashowtime.com" title="">Batavia Showtime</a></li>
<li class="leaf"><span class="nolink">Batavia Tailors &amp; Cleaners</span></li>
<li class="leaf"><a href="http://www.beds-n-bones.com/">Beds &#039;n&#039; Bones Pet Lodge</a></li>
<li class="leaf"><a href="https://www.belhavenkennels.com" title="">Belhaven Kennels</a></li>
<li class="leaf"><span class="nolink">Bill Fox and Son Construction &amp; Remodeling</span></li>
<li class="leaf"><a href="http://www.bontragerauction.com/">Bontrager&#039;s Real Estate</a></li>
<li class="leaf"><a href="http://www.bourbonandburger.com/#!" title="">Bourbon &amp; Burger Co.</a></li>
<li class="leaf"><a href="http://www.bubbaslandscape.net" title="">Bubba&#039;s Landscaping</a></li>
<li class="leaf"><a href="https://www.facebook.com/Byronhotelandtrailhouse" title="">Byron Hotel &amp; Trail House</a></li>
<li class="leaf"><a href="https://www.facebook.com/CSPGO" title="">Cancer Services Program</a></li>
<li class="leaf"><a href="https://www.facebook.com/The-Caryville-Inn-766671390026087/?fref=ts" title="">The Caryville Inn</a></li>
<li class="leaf"><a href="http://www.castilonechryslerdodgejeep.net/index.htm" title="">Castilone Chrysler Dodge Jeep</a></li>
<li class="leaf"><span class="nolink">CB Beach Mortuary</span></li>
<li class="leaf"><a href="http://www.cedarstreetonline.com/">Cedar St. Sales and Rentals</a></li>
<li class="leaf"><a href="http://www.centerstreetsmokehouse.com/">Center Street Smokehouse</a></li>
<li class="leaf"><a href="https://www.facebook.com/ChapsElbaDiner?fref=ts" title="">Chap&#039;s Elba Diner &amp; Catering</a></li>
<li class="leaf"><a href="http://www.chesleysauto.com" title="">Chesley&#039;s Auto</a></li>
<li class="leaf"><a href="https://www.facebook.com/CindysBarbs-188291215343031/" title="">Cindy &amp; Barb&#039;s Restaurant</a></li>
<li class="leaf"><a href="http://www.classicopticalbatavia.com/" title="">Classic Optical</a></li>
<li class="leaf"><a href="http://www.councilbatavia.com/">Council Opticians</a></li>
<li class="leaf"><a href="http://www.countryline.biz" title="">Country Line Electric</a></li>
<li class="leaf"><a href="http://www.crazycheapcars.com/">Crazy Cheap Cars</a></li>
<li class="leaf"><a href="http://danstire.com/">Dan&#039;s Tire</a></li>
<li class="leaf"><a href="http://www.darienlake.com" title="">Darien Lake</a></li>
<li class="leaf"><a href="http://www.dandrdepot.com/">D&amp;R Depot Restaurant</a></li>
<li class="leaf"><a href="https://www.facebook.com/pages/Daves-Ice-Cream/538860869467311" title="">Dave&#039;s Ice Cream</a></li>
<li class="leaf"><a href="http://www.deepbluepoolandspa.com/">Deep Blue Pool &amp; Spa</a></li>
<li class="leaf"><a href="http://webmaster732.wixsite.com/dennys" title="">Denny&#039;s Pool World</a></li>
<li class="leaf"><a href="http://www.derrickmonumentcompany.com/">Derrick Monument Company</a></li>
<li class="leaf"><a href="https://thedivinetree.co" title="">The Divine Tree</a></li>
<li class="leaf"><a href="http://www.dolcepanepinto.com" title="">Dolce Panepinto Attorneys At Law</a></li>
<li class="leaf"><a href="http://www.dumbleton.com" title="">Dumbleton&#039;s Used Auto Parts</a></li>
<li class="leaf"><a href="https://elifishbrewing.com" title="">Eli Fish Brewing Co.</a></li>
<li class="leaf"><a href="http://www.empireaccess.com" title="">Empire Access</a></li>
<li class="leaf"><a href="http://www.erieeast.com" title="">Erie East Windows &amp; Doors</a></li>
<li class="leaf"><a href="https://www.facebook.com/pages/Fab-Fajita-Pita/1033621993415084?fref=ts" title="">Fab Fajita &amp; Pita</a></li>
<li class="leaf"><a href="http://www.falconefuneralhome.com/">Falcone Family Funeral &amp; Cremation Service Inc.</a></li>
<li class="leaf"><a href="http://www.falleti.com/">Falleti Motors</a></li>
<li class="leaf"><a href="https://www.farmerscreekside.com" title="">Farmer&#039;s Creekside Tavern &amp; Inn</a></li>
<li class="leaf"><a href="http://www.fastecautomotive.com/">Fastec Automotive</a></li>
<li class="leaf"><a href="http://www.ficarellaspizzabatavia.com/">Ficarella&#039;s Pizzeria</a></li>
<li class="leaf"><a href="http://www.powdercoattoday.com">The Finishing Line</a></li>
<li class="leaf"><a href="http://www.1stchoicetravel.com/" title="">First Choice Travel</a></li>
<li class="leaf"><a href="http://www.floralfantasiesbatavia.com/">Floral Fantasies</a></li>
<li class="leaf"><a href="http://stores.ebay.com/FOXPROWL" title="">Foxprowl Collectibles</a></li>
<li class="leaf"><a href="https://www.facebook.com/geneseecouncil/" title="">GCASA</a></li>
<li class="leaf"><a href="http://www.co.genesee.ny.us/departments/health/radon2.html" title="">Genesee County Health Department</a></li>
<li class="leaf"><a href="http://www.geneseedental.com/">Genesee Dental Group</a></li>
<li class="leaf"><a href="http://www.geracerealty.com" title="">Gerace Realty - Robert J. Gerace</a></li>
<li class="leaf"><a href="http://www.gilmartinfuneralhome.com/" title="">Gilmartin Funeral Home &amp; Cremation Company, Inc.</a></li>
<li class="leaf"><a href="http://www.godfreyspond.org/">Godfrey&#039;s Pond</a></li>
<li class="leaf"><a href="http://www.greensofleroy.com" title="">Greens of LeRoy</a></li>
<li class="leaf"><a href="https://www.geneseehabitat.com" title="">Habitat for Humanity - ReStore</a></li>
<li class="leaf"><a href="http://www.hairstudio25.com/">Hair Studio 25</a></li>
<li class="leaf"><a href="http://www.hardcoraudio.com/">Hardcor Audio</a></li>
<li class="leaf"><a href="http://www.harriswilcox.com/home/" title="">Harris Wilcox Inc.</a></li>
<li class="leaf"><a href="http://www.bataviafuneralhomes.com/">H.E. Turner &amp; Co.</a></li>
<li class="leaf"><a href="http://www.haul-4-less.com/">Haul-4-Less</a></li>
<li class="leaf"><a href="http://henryhcook.com" title="">Henry H. Cook Inc.</a></li>
<li class="leaf"><a href="http://hiddenvalleyadventure.com" title="">Hidden Valley Animal Adventure</a></li>
<li class="leaf"><a href="http://www.hvolttattoo.com/">High Voltage Tattoo</a></li>
<li class="leaf"><a href="http://www.horizon-health.org" title="">Horizon Health Services</a></li>
<li class="leaf"><a href="http://www.htpartners.net/">Humphrey&#039;s Electric &amp; Security</a></li>
<li class="leaf"><a href="http://www.mcandrewfuneralhomes.net/">J. Leonard McAndrew</a></li>
<li class="leaf"><a href="https://www.facebook.com/pages/Jagged-Edges-Salon/117143028365903" title="">Jagged Edges Salon</a></li>
<li class="leaf"><span class="nolink">John&#039;s Service Station</span></li>
<li class="leaf"><a href="http://www.johnsonselderlycare.com" title="">Johnson&#039;s Elderly Care</a></li>
<li class="leaf"><a href="http://www.kenbarrett.com/">Ken Barrett</a></li>
<li class="leaf"><a href="http://www.bataviakiwanis.org" title="">Kiwanis</a></li>
<li class="leaf"><a href="http://www.kreativedesignkitchenandbath.com/">Kreative Design Kitchen &amp; Bath</a></li>
<li class="leaf"><a href="http://www.landltransmissions.com/">L&amp;L Transmission, Inc.</a></li>
<li class="leaf"><a href="https://www.facebook.com/pg/LBGrand/about/?ref=page_internal" title="">LB Grand</a></li>
<li class="leaf"><a href="http://www.lambertsjewelers.com">Lambert&#039;s Design Jewelers</a></li>
<li class="leaf"><a href="https://www.facebook.com/liviabeautyspa/?hc_ref=SEARCH&amp;fref=nf" title="">Livia Beauty &amp; Spa</a></li>
<li class="leaf"><a href="http://www.andoll.com" title="">Louis Andolora</a></li>
<li class="leaf"><a href="http://www.mainstpizzacompany.com/">Main St. Pizza Company</a></li>
<li class="leaf"><a href="http://themanorhousesc.com/" title="">Manor House</a></li>
<li class="leaf"><a href="http://mcpinc.com" title="">Marchese Computer</a></li>
<li class="leaf"><a href="https://mariescofield.kw.com" title="">Marie Scofield, Keller Williams</a></li>
<li class="leaf"><span class="nolink">Matteo &amp; Mullen, CPA</span></li>
<li class="leaf"><a href="http://www.maxpiesfurniture.com/">Max Pies</a></li>
<li class="leaf"><span class="nolink">O&#039;Lacy&#039;s Irish Pub</span></li>
<li class="leaf"><a href="http://www.oakfieldfitness.com/">Oakfield Fitness</a></li>
<li class="leaf"><a href="http://www.qualityinnbatavia.com/oasis-restaurant.html" title="">Oasis Restaurant</a></li>
<li class="leaf"><a href="http://oliverscandies.com/">Oliver&#039;s Candies</a></li>
<li class="leaf"><span class="nolink">Optique</span></li>
<li class="leaf"><a href="http://www.orleans4-hfair.com" title="">Orleans County Fair</a></li>
<li class="leaf"><a href="http://www.pandlair.com" title="">P&amp;L Air</a></li>
<li class="leaf"><a href="http://www.ficarellaspizzaleroy.com" title="">Pastore&#039;s Pizzeria</a></li>
<li class="leaf"><a href="http://www.pellegrinoautosales.com/">Pellegrino Auto Sales</a></li>
<li class="leaf"><a href="http://www.thebatavian.com/bowling" title="">Pin Points</a></li>
<li class="leaf"><a href="https://www.facebook.com/pg/Precision-Lawn-Care-LLC-LeRoy-NY-169998196482947/about/?ref=page_internal" title="">Precision Lawn Care</a></li>
<li class="leaf"><a href="http://www.randdoutletcenter.com/">R&amp;D Outlet</a></li>
<li class="leaf"><a href="http://www.rwvapors.com/">RW Vapors</a></li>
<li class="leaf"><a href="http://www.reedeye.com" title="">Reed Eye Associates</a></li>
<li class="leaf"><a href="https://www.myrts.com/Work-for-RTS?JobID=1" title="">Regional Transit Service</a></li>
<li class="leaf"><a href="http://www.riderrealestate.com" title="">Rider Real Estate</a></li>
<li class="leaf"><a href="https://www.rochesterregional.org/find-a-doctor/ummc/" title="">Rochester Regional Health @ UMMC</a></li>
<li class="leaf"><a href="http://sallomehvac.com" title="">Sallome Heating &amp; Cooling</a></li>
<li class="leaf"><span class="nolink">Santino&#039;s Pizza</span></li>
<li class="leaf"><a href="http://www.selectcollisionny.com" title="">Select Collision</a></li>
<li class="leaf"><a href="http://www.settlersrestaurant.com/">Settler&#039;s Restaurant</a></li>
<li class="leaf"><a href="https://sixsensesescaperooms.com" title="">Six Senses Escape Rooms</a></li>
<li class="leaf"><a href="http://www.skylinervresort.com" title="">Skyline RV Sales &amp; Service</a></li>
<li class="leaf"><span class="nolink">Sloat&#039;s Tire</span></li>
<li class="leaf"><a href="https://www.facebook.com/pages/Smokin-Eagle-BBQ/171066096336858?fref=ts">Smokin&#039; Eagle Brew &amp; BBQ</a></li>
<li class="leaf"><a href="http://www.southsidedeli.com/">Southside Deli</a></li>
<li class="leaf"><a href="https://www.facebook.com/pages/Stella-Collision-Serv-Inc/163791313638569" title="">Stella Collision</a></li>
<li class="leaf"><a href="http://www.tfbrowns.com/">T.F. Brown&#039;s</a></li>
<li class="leaf"><a href="http://www.smhawley.com/">The Insurance Center</a></li>
<li class="leaf"><span title="" class="nolink">The Oak Grill &amp; Cafe</span></li>
<li class="leaf"><a href="http://www.redosier.com" title="">The Red Osier Landmark Restaurant, Stafford</a></li>
<li class="leaf"><a href="http://www.thompsonmotorsllc.com" title="">Thompson Motors</a></li>
<li class="leaf"><a href="http://www.tomaszewskifh.com/">Tomaszewski Funeral &amp; Cremation Chapel</a></li>
<li class="leaf"><a href="https://www.tompkinsins.com" title="">Tompkins Bank of Castle Insurance</a></li>
<li class="leaf"><a href="http://toyotaofbatavia.calls.net/?utm_source=google&amp;utm_content=ZRgptxKl&amp;utm_medium=cpc&amp;utm_campaign=PaidSearch&amp;siteid=SEM_GNY10_google_paidsearch&amp;utm_term=toyota+of+batavia+ny" title="">Toyota of Batavia</a></li>
<li class="leaf"><a href="https://batavia-ny-6157.theupsstorelocal.com" title="">UPS Store</a></li>
<li class="leaf"><a href="http://vallejewelersbatavia.com/">Valle Jewelers</a></li>
<li class="leaf"><a href="http://www.wnyfireplaceoutlet.com/">WNY Fireplace Outlet</a></li>
<li class="leaf"><a href="http://www.facebook.com/pages/West-Main-Wine-and-Spirits/208995262447108">West Main Wine &amp; Spirits</a></li>
<li class="leaf"><span class="nolink">Western Regional Off Track</span></li>
<li class="leaf"><a href="http://www.williamkentinc.com/">William Kent, Inc.</a></li>
<li class="leaf"><a href="http://www.glowymca.org" title="">YMCA</a></li>
<li class="leaf"><a href="http://www.yassestruckingandconstruction.com" title="">Yasses Construction</a></li>
<li class="leaf"><a href="https://www.facebook.com/TheYngodessShop">Yngodess Shop</a></li>
<li class="last leaf"><a href="https://www.facebook.com/Yume-Asian-Bistro-241123629393541/?fref=ts" title="">Yume Asian Bistro</a></li>
</ul> </div>
</div>
</div>
<div class="panel-panel page-col">
<div class="inside"><div class="panel-pane pane-ad pane-1244 broadstreet-ad broadstreet-1244">
<script type="text/javascript">if (typeof broadstreet !== 'undefined') broadstreet.zone(1244);</script>
</div>
<div class="panel-pane pane-page-title">
<h1></h1>
</div>
<div class="panel-pane pane-page-content">
<div class="panel-pane pane-node-created">
September 1, 2018 - 1:15pm </div>
<div class="panel-pane pane-node-title">
<h1>Blue Devils easily knock off top-ranked Hornell in season opener</h1>
</div>
<div class="panel-pane pane-node-submission">
posted by <span class="username">Howard B. Owens</span> in <a href="/tags/football">football</a>, <a href="/sports">sports</a>, <a href="/batavia">batavia</a>, <a href="/tags/batavia-hs">Batavia HS</a>, <a href="/tags/news">news</a>. </div>
<div class="panel-pane pane-entity-field pane-node-body">
<div class="field field--name-body field--type-text-with-summary field--label-hidden"><div class="field__items"><div class="field__item even"><p><img alt="bluedevlis2018set2.jpg" src="/files/users/60/2018-08/bluedevlis2018set2.jpg" style="width:460px;height:307px;" /></p>
<p>The Batavia Blue Devils have a message for the rest of Section V Class B: We're coming for the block.</p>
<p>They delivered that message loud and clear last night to #2 ranked Hornell (Batavia is ranked #1), the team that took the block (the Section V sectional trophy) from them in 2017, with a convincing 48-14 win at home.</p>
<p>The Blue Devils relished the win against a perennial Class B rival and Southern Tier powerhouse.</p>
<p>"It means a lot," said senior QB Ethan Biscaro. "To lose last year (in the Section V title game) and have them open up here at home, it couldn’t have been any better."</p>
<p>The message the rest of the class might want to heed is the 2018 Blue Devils are more than their two-time All-Greater-Rochester star Ray Leach. This team has weapons in players like Biscaro, Alex Rood, and Cody Burns who can also chew up yards and put points on the board.</p>
<p>Batavia had 379 total yards on the ground. Rood carried the ball 13 times for 168 yards and a TD. Burns had five carries for 95 yards and a TD. And Leach ran 14 times for 88 yards and two TDs.</p>
<p>Biscaro was also 3-5 passing for 32 yards and a TD. Burns had the TD reception.</p>
<p>Head coach Brennan Briggs can't deny he's excited by the talent on the team but he also pointed out, it's one game, it's early in the season, the team still has a lot to learn and improve on and if they don't improve every week they won't be able to handle the rigors of post-season play.</p>
<p>"I'm never going to get complacent with where we are I can guarantee that," Briggs said. "I'll be watching film tonight. I'll be watching it tomorrow morning. I'll be going down watching Lavonia a couple hours away tomorrow. So we'll we'll have his team ready to go next week and we'll fix our mistakes and hopefully get better every day."</p>
<p>Briggs is never going to come into a game expecting his team to lose, even against a team like Hornell, but he did not predict a blow-out win.</p>
<p>"I still don't know if the score tells the true story," Briggs said. "You know, as the season goes on we'll see. This is a great win. But you know it's going to be more important if we see them in the sectionals, sometime in the sectional tournament, to see if we play our best game against them."</p>
<p>Rood and Leach, along with Briggs, gave all the credit to the offensive line for the team's dominant performance offensively.</p>
<p>"They did a fantastic job and we're tough on them," Briggs said. "We're as tough on them as any of the positions on the team because we told them, 'hey you know you win or lose games up front.' They take pride in it. They're a brotherhood."</p>
<p>For Burns, a junior, this was a break-out game. At 5'6", he's one of the smallest players on the field but he plays big. And he's fast. He scored his TD on a busted play where the offensive line pushed left and he ran right. By the time the Hornell defense realized it was following the line and not the ball, it was too late. Burns was gone. Nobody could catch him. He streaked more than 60 yards untouched for a TD.</p>
<p>On defense, he started at linebacker. Yes, at 150 pounds, linebacker.</p>
<p>"On defense, he plays tough," Briggs said. "He's not big at all but he'll bring it. He's ready to go bust the wedge on kickoff or knock their teeth in."</p>
<p>This season was also a test for the home team. They had to show they could overcome off-season turmoil and focus on football.</p>
<p>A month ago, Leach and teammate Antwan Odom got into a fight on Ross Street. Odom is accused of pulling out a pocket knife and stabbing Leach at least 10 times, leaving him with eight wounds that required stitches.</p>
<p>Briggs said his players did a good job of keeping the off-field antics out of the locker room and off the practice field.</p>
<p>"Everybody really put it behind them," Briggs said. "It's an unfortunate thing but you know we're here now and we're living in the moment and moving forward."</p>
<p>Leach said he's feeling much better and came into the game ready for the season.</p>
<p>"I just had to stay positive and lean on my teammates," Leach said. "My teammates picked me up and I just had to work hard and practice on whatever little things I can do."</p>
<p>Also in Genesee County football on Friday: </p>
<ul><li>Alexander beat York-Pavilion 50 to 12. Chris McClinic had 11 carries for 149 yards and 1 TD run and 1 kick return for TD. Terrez Smith rushed five times for 146 yards and three touchdowns. Ty Woods hauled in three passes for 64 yards and a TD.  QB Dylan Busch was 6-7 for 81 yards and a TD.  Jake Jasen had 19 tackles. He also rushed three times for 15 yards and TD late in the game.</li>
<li>Geneseo beat Pembroke 30-9.</li>
<li>Le Roy beat Avon 47-13. Le Roy's offense rolled up 413 total yards. Cineque Robinson had 11 carries for 113 yards and a touchdown, Jake Hill had eight rushes for 93 yards and two TDs, Kyler LaCarte picked up 62 yards on 13 touches and scored twice. Hill was 5-10 passing for  60 yards and TD. Anthony Leitte led the team with seven tackles.</li>
</ul><p>Top Photo: Biscaro (#8) and Burns (#12) celebrate after Burns scored a TD on a busted play.</p>
<p><img alt="bluedevlis2018set2-2.jpg" src="/files/users/60/2018-08/bluedevlis2018set2-2.jpg" style="width:460px;height:307px;" /></p>
<p>Alex Rood</p>
<p><img alt="bluedevlis2018set2-3.jpg" src="/files/users/60/2018-08/bluedevlis2018set2-3.jpg" style="width:460px;height:307px;" /></p>
<p>Biscaro scores.</p>
<p><img alt="bluedevlis2018set2-4.jpg" src="/files/users/60/2018-08/bluedevlis2018set2-4.jpg" style="width:460px;height:307px;" /></p>
<p>Leach just about to cross the goal line on the second of his two TDs.</p>
<p><img alt="bluedevlis2018set2-5.jpg" src="/files/users/60/2018-08/bluedevlis2018set2-5.jpg" style="width:460px;height:307px;" /></p>
<p>Rood with a tackle in the backfield. He had eight tackles to lead the team Friday.</p>
<p><img alt="bluedevlis2018set2-6.jpg" src="/files/users/60/2018-08/bluedevlis2018set2-6.jpg" style="width:460px;height:307px;" /></p>
<p>Rood breaks away for another TD.</p>
<p><img alt="bluedevlis2018set2-7.jpg" src="/files/users/60/2018-08/bluedevlis2018set2-7.jpg" style="width:460px;height:307px;" /></p>
<p>Burns</p>
<p>To purchase prints for photos, <a href="https://www.howardowensphotography.com/p996911802" target="_blank">click here</a>.</p>
<p><iframe frameborder="0" height="360" scrolling="0" src="//www.howardowensphotography.com/zf/core/embedgallery.aspx?p=3b6baaba0ff405211CCCCCC03e111111F5F5F5DDDDDD555555CCCCCC.2" style="background-color:#555555;" width="480"></iframe></p>
</div></div></div> </div>
<div class="panel-pane pane-social-share">
<a href="https://www.facebook.com/sharer/sharer.php?u=http://www.thebatavian.com/howard-b-owens/blue-devils-easily-knock-off-top-ranked-hornell-in-season-opener/520826" target="_blank" class="share-facebook" title="Share this page on Facebook" data-url="http://www.thebatavian.com/howard-b-owens/blue-devils-easily-knock-off-top-ranked-hornell-in-season-opener/520826"><img src="/sites/all/themes/omega_batavian/images/facebook.png" alt="Share this page on Facebook" />Recommend</a><a href="https://twitter.com/intent/tweet/?text=Blue+Devils+easily+knock+off+top-ranked+Hornell+in+season+opener&url=http://www.thebatavian.com/howard-b-owens/blue-devils-easily-knock-off-top-ranked-hornell-in-season-opener/520826&via=thebatavian" target="_blank" class="share-twitter" title="Share this page on Twitter"><img src="/sites/all/themes/omega_batavian/images/twitter.png" alt="Share this page on Twitter" />Tweet</a><a href="https://pinterest.com/pin/create/button/?url=http://www.thebatavian.com/howard-b-owens/blue-devils-easily-knock-off-top-ranked-hornell-in-season-opener/520826&media=http://www.thebatavian.com/files/users/60/2018-08/bluedevlis2018set2.jpg&description=" target="_blank" class="share-pinterest" title="Share this page on Pinterest"><img src="/sites/all/themes/omega_batavian/images/pinterest.png" alt="Share this page on Pinterest" />Pin it</a> </div>
<div class="panel-pane pane-node-comment-form">
<h2 class="pane-title">Post new comment</h2>
<a href="/user/login?destination=node/520826%23comment-form">Log in</a> or <a href="/user/register?destination=node/520826%23comment-form">register</a> to post comments </div>
</div>
</div>
</div>
<div class="panel-panel page-col-last">
<div class="inside"><div class="panel-pane pane-ad pane-1945 broadstreet-ad broadstreet-1945">
<script type="text/javascript">if (typeof broadstreet !== 'undefined') broadstreet.zone(1945);</script>
</div>
<div class="panel-pane pane-ad pane-1258 broadstreet-ad broadstreet-1258">
<script type="text/javascript">if (typeof broadstreet !== 'undefined') broadstreet.zone(1258);</script>
</div>
<div class="panel-pane pane-block pane-broadstreet-ads-1949">
<script type="text/javascript">if (typeof broadstreet !== 'undefined') broadstreet.zone(1949);</script>
</div>
<div class="panel-pane pane-views pane-upcoming-events">
<h2 class="pane-title">Calendar</h2>
<div class="view view-upcoming-events view-id-upcoming_events view-display-id-block view-dom-id-28c4e18406afe4154401f0553d8b97a0">
<div class="view-header">
<div class="date-nav-wrapper clearfix">
<div class="date-nav item-list">
<div class="date-heading">
<h3><a href="http://www.thebatavian.com/calendar-node-field-event-date-time/month/2018-09" title="View full page month">September 2018</a></h3>
</div>
<ul class="pager">
<li class="date-prev">
<a href="http://www.thebatavian.com/howard-owens/photos-closing-ceremony-sand-mandala-gcc/31701?mini=2018-08" title="Navigate to previous month" rel="nofollow">&laquo;</a> </li>
<li class="date-next">
<a href="http://www.thebatavian.com/howard-owens/photos-closing-ceremony-sand-mandala-gcc/31701?mini=2018-10" title="Navigate to next month" rel="nofollow">&raquo;</a> </li>
</ul>
</div>
</div>
</div>
<div class="view-content">
<div class="calendar-calendar"><div class="month-view">
<table class="mini">
<thead>
<tr>
<th class="days sun">
S </th>
<th class="days mon">
M </th>
<th class="days tue">
T </th>
<th class="days wed">
W </th>
<th class="days thu">
T </th>
<th class="days fri">
F </th>
<th class="days sat">
S </th>
</tr>
</thead>
<tbody>
<tr>
<td id="upcoming_events-2018-08-26" class="sun mini empty">
<div class="calendar-empty">&nbsp;</div>
</td>
<td id="upcoming_events-2018-08-27" class="mon mini empty">
<div class="calendar-empty">&nbsp;</div>
</td>
<td id="upcoming_events-2018-08-28" class="tue mini empty">
<div class="calendar-empty">&nbsp;</div>
</td>
<td id="upcoming_events-2018-08-29" class="wed mini empty">
<div class="calendar-empty">&nbsp;</div>
</td>
<td id="upcoming_events-2018-08-30" class="thu mini empty">
<div class="calendar-empty">&nbsp;</div>
</td>
<td id="upcoming_events-2018-08-31" class="fri mini empty">
<div class="calendar-empty">&nbsp;</div>
</td>
<td id="upcoming_events-2018-09-01" class="sat mini today has-events">
<div class="month mini-day-on"> <a href="http://www.thebatavian.com/calendar-node-field-event-date-time/day/2018-09-01">1</a> </div><div class="calendar-empty">&nbsp;</div>
</td>
</tr>
<tr>
<td id="upcoming_events-2018-09-02" class="sun mini future has-no-events">
<div class="month mini-day-off"> 2 </div><div class="calendar-empty">&nbsp;</div>
</td>
<td id="upcoming_events-2018-09-03" class="mon mini future has-no-events">
<div class="month mini-day-off"> 3 </div><div class="calendar-empty">&nbsp;</div>
</td>
<td id="upcoming_events-2018-09-04" class="tue mini future has-no-events">
<div class="month mini-day-off"> 4 </div><div class="calendar-empty">&nbsp;</div>
</td>
<td id="upcoming_events-2018-09-05" class="wed mini future has-events">
<div class="month mini-day-on"> <a href="http://www.thebatavian.com/calendar-node-field-event-date-time/day/2018-09-05">5</a> </div><div class="calendar-empty">&nbsp;</div>
</td>
<td id="upcoming_events-2018-09-06" class="thu mini future has-no-events">
<div class="month mini-day-off"> 6 </div><div class="calendar-empty">&nbsp;</div>
</td>
<td id="upcoming_events-2018-09-07" class="fri mini future has-no-events">
<div class="month mini-day-off"> 7 </div><div class="calendar-empty">&nbsp;</div>
</td>
<td id="upcoming_events-2018-09-08" class="sat mini future has-events">
<div class="month mini-day-on"> <a href="http://www.thebatavian.com/calendar-node-field-event-date-time/day/2018-09-08">8</a> </div><div class="calendar-empty">&nbsp;</div>
</td>
</tr>
<tr>
<td id="upcoming_events-2018-09-09" class="sun mini future has-events">
<div class="month mini-day-on"> <a href="http://www.thebatavian.com/calendar-node-field-event-date-time/day/2018-09-09">9</a> </div><div class="calendar-empty">&nbsp;</div>
</td>
<td id="upcoming_events-2018-09-10" class="mon mini future has-events">
<div class="month mini-day-on"> <a href="http://www.thebatavian.com/calendar-node-field-event-date-time/day/2018-09-10">10</a> </div><div class="calendar-empty">&nbsp;</div>
</td>
<td id="upcoming_events-2018-09-11" class="tue mini future has-events">
<div class="month mini-day-on"> <a href="http://www.thebatavian.com/calendar-node-field-event-date-time/day/2018-09-11">11</a> </div><div class="calendar-empty">&nbsp;</div>
</td>
<td id="upcoming_events-2018-09-12" class="wed mini future has-events">
<div class="month mini-day-on"> <a href="http://www.thebatavian.com/calendar-node-field-event-date-time/day/2018-09-12">12</a> </div><div class="calendar-empty">&nbsp;</div>
</td>
<td id="upcoming_events-2018-09-13" class="thu mini future has-events">
<div class="month mini-day-on"> <a href="http://www.thebatavian.com/calendar-node-field-event-date-time/day/2018-09-13">13</a> </div><div class="calendar-empty">&nbsp;</div>
</td>
<td id="upcoming_events-2018-09-14" class="fri mini future has-no-events">
<div class="month mini-day-off"> 14 </div><div class="calendar-empty">&nbsp;</div>
</td>
<td id="upcoming_events-2018-09-15" class="sat mini future has-events">
<div class="month mini-day-on"> <a href="http://www.thebatavian.com/calendar-node-field-event-date-time/day/2018-09-15">15</a> </div><div class="calendar-empty">&nbsp;</div>
</td>
</tr>
<tr>
<td id="upcoming_events-2018-09-16" class="sun mini future has-events">
<div class="month mini-day-on"> <a href="http://www.thebatavian.com/calendar-node-field-event-date-time/day/2018-09-16">16</a> </div><div class="calendar-empty">&nbsp;</div>
</td>
<td id="upcoming_events-2018-09-17" class="mon mini future has-events">
<div class="month mini-day-on"> <a href="http://www.thebatavian.com/calendar-node-field-event-date-time/day/2018-09-17">17</a> </div><div class="calendar-empty">&nbsp;</div>
</td>
<td id="upcoming_events-2018-09-18" class="tue mini future has-events">
<div class="month mini-day-on"> <a href="http://www.thebatavian.com/calendar-node-field-event-date-time/day/2018-09-18">18</a> </div><div class="calendar-empty">&nbsp;</div>
</td>
<td id="upcoming_events-2018-09-19" class="wed mini future has-no-events">
<div class="month mini-day-off"> 19 </div><div class="calendar-empty">&nbsp;</div>
</td>
<td id="upcoming_events-2018-09-20" class="thu mini future has-events">
<div class="month mini-day-on"> <a href="http://www.thebatavian.com/calendar-node-field-event-date-time/day/2018-09-20">20</a> </div><div class="calendar-empty">&nbsp;</div>
</td>
<td id="upcoming_events-2018-09-21" class="fri mini future has-events">
<div class="month mini-day-on"> <a href="http://www.thebatavian.com/calendar-node-field-event-date-time/day/2018-09-21">21</a> </div><div class="calendar-empty">&nbsp;</div>
</td>
<td id="upcoming_events-2018-09-22" class="sat mini future has-events">
<div class="month mini-day-on"> <a href="http://www.thebatavian.com/calendar-node-field-event-date-time/day/2018-09-22">22</a> </div><div class="calendar-empty">&nbsp;</div>
</td>
</tr>
<tr>
<td id="upcoming_events-2018-09-23" class="sun mini future has-no-events">
<div class="month mini-day-off"> 23 </div><div class="calendar-empty">&nbsp;</div>
</td>
<td id="upcoming_events-2018-09-24" class="mon mini future has-no-events">
<div class="month mini-day-off"> 24 </div><div class="calendar-empty">&nbsp;</div>
</td>
<td id="upcoming_events-2018-09-25" class="tue mini future has-events">
<div class="month mini-day-on"> <a href="http://www.thebatavian.com/calendar-node-field-event-date-time/day/2018-09-25">25</a> </div><div class="calendar-empty">&nbsp;</div>
</td>
<td id="upcoming_events-2018-09-26" class="wed mini future has-no-events">
<div class="month mini-day-off"> 26 </div><div class="calendar-empty">&nbsp;</div>
</td>
<td id="upcoming_events-2018-09-27" class="thu mini future has-no-events">
<div class="month mini-day-off"> 27 </div><div class="calendar-empty">&nbsp;</div>
</td>
<td id="upcoming_events-2018-09-28" class="fri mini future has-no-events">
<div class="month mini-day-off"> 28 </div><div class="calendar-empty">&nbsp;</div>
</td>
<td id="upcoming_events-2018-09-29" class="sat mini future has-events">
<div class="month mini-day-on"> <a href="http://www.thebatavian.com/calendar-node-field-event-date-time/day/2018-09-29">29</a> </div><div class="calendar-empty">&nbsp;</div>
</td>
</tr>
<tr>
<td id="upcoming_events-2018-09-30" class="sun mini future has-events">
<div class="month mini-day-on"> <a href="http://www.thebatavian.com/calendar-node-field-event-date-time/day/2018-09-30">30</a> </div><div class="calendar-empty">&nbsp;</div>
</td>
<td id="upcoming_events-2018-10-01" class="mon mini empty">
<div class="calendar-empty">&nbsp;</div>
</td>
<td id="upcoming_events-2018-10-02" class="tue mini empty">
<div class="calendar-empty">&nbsp;</div>
</td>
<td id="upcoming_events-2018-10-03" class="wed mini empty">
<div class="calendar-empty">&nbsp;</div>
</td>
<td id="upcoming_events-2018-10-04" class="thu mini empty">
<div class="calendar-empty">&nbsp;</div>
</td>
<td id="upcoming_events-2018-10-05" class="fri mini empty">
<div class="calendar-empty">&nbsp;</div>
</td>
<td id="upcoming_events-2018-10-06" class="sat mini empty">
<div class="calendar-empty">&nbsp;</div>
</td>
</tr>
</tbody>
</table>
</div></div> </div>
<div class="view-footer">
<p><a href="/user/login">Login</a> or <a href="/user/register">register</a> to add an event.</p> </div>
</div> </div>
<div class="panel-pane pane-views pane-upcoming-events">
<h2 class="pane-title">Upcoming</h2>
<div class="view view-upcoming-events view-id-upcoming_events view-display-id-upcoming view-dom-id-7f9aadf3a143679f30df3a433f9924a0">
<div class="view-content">
<div class="item-list"><ul> <li class="views-row views-row-1 views-row-odd views-row-first">
<div class="views-field views-field-title"> <span class="field-content"><a href="/events/community-outreach-free-food-clothes-shoes/519977">Community Outreach - Free food, clothes &amp; shoes</a></span> </div>
<div class="views-field views-field-field-event-date-time"> <div class="field-content"><span class="date-display-single">Sep 1 2018 - <span class="date-display-range"><span class="date-display-start">12:00pm</span> to <span class="date-display-end">5:00pm</span></span></span></div> </div></li>
<li class="views-row views-row-2 views-row-even">
<div class="views-field views-field-title"> <span class="field-content"><a href="/events/letters-from-home-uso-type-show-for-vets-families-at-nys-veterans-home-free/520583">&#039;Letters From Home&#039; USO-type show for vets &amp; families at NYS Veterans Home, free</a></span> </div>
<div class="views-field views-field-field-event-date-time"> <div class="field-content"><span class="date-display-single">Sep 5 2018 - 2:00pm</span></div> </div></li>
<li class="views-row views-row-3 views-row-odd">
<div class="views-field views-field-title"> <span class="field-content"><a href="/events/gcc-history-club-launches-fall-lecture-series-with-talk-on-americas-bloodiest-single-day-the">GCC History Club launches fall lecture series with talk on &#039;America&#039;s bloodiest single day&#039; -- the Battle of Antietam</a></span> </div>
<div class="views-field views-field-field-event-date-time"> <div class="field-content"><span class="date-display-single">Sep 5 2018 - 7:00pm</span></div> </div></li>
<li class="views-row views-row-4 views-row-even">
<div class="views-field views-field-title"> <span class="field-content"><a href="/events/enjoy-an-afternoon-at-richmond-library-with-historical-portrayer-of-elizabeth-cady-stanton">Enjoy an afternoon at Richmond library with historical portrayer of Elizabeth Cady Stanton</a></span> </div>
<div class="views-field views-field-field-event-date-time"> <div class="field-content"><span class="date-display-single">Sep 8 2018 - 2:00pm</span></div> </div></li>
<li class="views-row views-row-5 views-row-odd views-row-last">
<div class="views-field views-field-title"> <span class="field-content"><a href="/events/fight-like-mike-chicken-bbq-at-the-yngodess-shop-to-benefit-mike-tenebruso/520799">&#039;Fight Like Mike&#039; chicken BBQ at The Yngodess Shop to benefit Mike Tenebruso </a></span> </div>
<div class="views-field views-field-field-event-date-time"> <div class="field-content"><span class="date-display-single">Sep 9 2018 - 12:30pm</span></div> </div></li>
</ul></div> </div>
<div class="more-link">
<a href="/calendar-node-field-event-date-time/month">
more </a>
</div>
</div> </div>
<div class="panel-pane pane-ad pane-1257 broadstreet-ad broadstreet-1257">
<script type="text/javascript">if (typeof broadstreet !== 'undefined') broadstreet.zone(1257);</script>
</div>
<div class="panel-pane pane-ad pane-40855 broadstreet-ad broadstreet-40855">
<script type="text/javascript">if (typeof broadstreet !== 'undefined') broadstreet.zone(40855);</script>
</div>
<div class="panel-pane pane-ad pane-1262 broadstreet-ad broadstreet-1262">
<script type="text/javascript">if (typeof broadstreet !== 'undefined') broadstreet.zone(1262);</script>
</div>
<div class="panel-pane pane-ad pane-1251 broadstreet-ad broadstreet-1251">
<script type="text/javascript">if (typeof broadstreet !== 'undefined') broadstreet.zone(1251);</script>
</div>
<div class="panel-pane pane-ad pane-1256 broadstreet-ad broadstreet-1256">
<script type="text/javascript">if (typeof broadstreet !== 'undefined') broadstreet.zone(1256);</script>
</div>
<div class="panel-pane pane-ad pane-1245 broadstreet-ad broadstreet-1245">
<script type="text/javascript">if (typeof broadstreet !== 'undefined') broadstreet.zone(1245);</script>
</div>
<div class="panel-pane pane-ad pane-1249 broadstreet-ad broadstreet-1249">
<script type="text/javascript">if (typeof broadstreet !== 'undefined') broadstreet.zone(1249);</script>
</div>
</div>
</div>
</div>
</div>
<div class="panel-panel panel-col-page-suffix clearfix">
<div class="inside"><div class="panel-pane pane-custom pane-2">
<p>Copyright © 2008-2018 <a href="http://thebatavian.com/" title="TheBatavian.com">The Batavian</a>. Some Rights Reserved. <a href="http://thebatavian.com/privacy-policy">Privacy Policy</a> | <a href="http://thebatavian.com/terms-of-service">Terms of Service</a><br />
Original content available for non-commercial use under a <a href="http://creativecommons.org/licenses/by-nc-nd/3.0/">Creative Commons license</a>.<br />
Contact: Howard Owens, publisher (howard (at) the batavian dot com); (585) 250-4118</p>
</div>
<div class="panel-pane pane-custom pane-3">
<p><a href="http://authenticallylocal.com"><img alt="blue button" src="http://static.tumblr.com/neq6kdr/SpUll1zvv/authenticallylocal_logo_red_web.png" /></a></p> </div>
</div>
</div>
</div>
<script type="text/javascript" src="/files/advagg_js/js___F8KGWIiHdQfl5bO6Dui8ksNE0NZVOw6z7uq1-lDB4k__tkY0XGqphgKxrpfoJ5XLMot4uI1j7Q6RUQjt3Ugx2Uc__utXHTkFnUKRmf6-l2oJ--4sEOpCnEq30N9WhiEympKQ.js"></script>
</body>
</html>
