<!DOCTYPE html>
<!--[if IEMobile 7]><html class="no-js ie iem7" lang="en" dir="ltr"><![endif]-->
<!--[if lte IE 6]><html class="no-js ie lt-ie9 lt-ie8 lt-ie7" lang="en" dir="ltr"><![endif]-->
<!--[if (IE 7)&(!IEMobile)]><html class="no-js ie lt-ie9 lt-ie8" lang="en" dir="ltr"><![endif]-->
<!--[if IE 8]><html class="no-js ie lt-ie9" lang="en" dir="ltr"><![endif]-->
<!--[if (gte IE 9)|(gt IEMobile 7)]><html class="no-js ie" lang="en" dir="ltr" prefix="og: http://ogp.me/ns#"><![endif]-->
<!--[if !IE]><!--><html class="no-js" lang="en" dir="ltr" prefix="og: http://ogp.me/ns#"><!--<![endif]-->
<head>
<title>Developer plans massive warehouse for retail overstock in Batavia business park | The Batavian</title>
<!--[if IE]><![endif]-->
<meta charset="utf-8" />
<script type="text/javascript" src="//cdn.broadstreetads.com/init.js"></script>
<link rel="apple-touch-icon" sizes="57x57" href="/files/favicons/apple-touch-icon-57x57.png" />
<link rel="apple-touch-icon" sizes="60x60" href="/files/favicons/apple-touch-icon-60x60.png" />
<link rel="apple-touch-icon" sizes="72x72" href="/files/favicons/apple-touch-icon-72x72.png" />
<link rel="apple-touch-icon" sizes="76x76" href="/files/favicons/apple-touch-icon-76x76.png" />
<link rel="apple-touch-icon" sizes="114x114" href="/files/favicons/apple-touch-icon-114x114.png" />
<link rel="apple-touch-icon" sizes="120x120" href="/files/favicons/apple-touch-icon-120x120.png" />
<link rel="apple-touch-icon" sizes="144x144" href="/files/favicons/apple-touch-icon-144x144.png" />
<link rel="apple-touch-icon" sizes="152x152" href="/files/favicons/apple-touch-icon-152x152.png" />
<link rel="apple-touch-icon" sizes="180x180" href="/files/favicons/apple-touch-icon-180x180.png" />
<link rel="icon" type="image/png" href="/files/favicons/favicon-32x32.png" sizes="32x32" />
<link rel="icon" type="image/png" href="/files/favicons/android-chrome-192x192.png" sizes="192x192" />
<link rel="icon" type="image/png" href="/files/favicons/favicon-96x96.png" sizes="96x96" />
<link rel="icon" type="image/png" href="/files/favicons/favicon-16x16.png" sizes="16x16" />
<link rel="manifest" href="/files/favicons/manifest.json" />
<meta name="msapplication-TileColor" content="#da532c" />
<meta name="msapplication-TileImage" content="/files/favicons/mstile-144x144.png" />
<meta name="theme-color" content="#ffffff" />
<link rel="shortcut icon" href="https://www.thebatavian.com/favicon.ico" type="image/vnd.microsoft.icon" />
<link rel="profile" href="https://www.w3.org/1999/xhtml/vocab" />
<meta name="HandheldFriendly" content="true" />
<meta name="MobileOptimized" content="width" />
<meta http-equiv="cleartype" content="on" />
<meta name="description" content="Mega Properties is planning another massive warehouse for the Gateway II industrial park east of Route 98 in the Town of Batavia. This time it will be a 200,000 square-foot warehouse available for area retailers to store inventory overstock. Lucas Bushen, with Marathon Engineering, presented initial plans to the town planning board on Tuesday. He said there will be few" />
<meta name="keywords" content="Mega Properties, batavia, news, Gateway II" />
<meta name="viewport" content="width=device-width" />
<link rel="image_src" href="https://www.thebatavian.com/files/users/60/2022-05/lucasbushenplanning2022.jpg" />
<meta name="generator" content="Drupal 7 (http://drupal.org)" />
<link rel="canonical" href="https://www.thebatavian.com/howard-b-owens/developer-plans-massive-warehouse-for-retail-overstock-in-batavia-business-park" />
<link rel="shortlink" href="https://www.thebatavian.com/node/605553" />
<meta property="og:site_name" content="The Batavian" />
<meta property="og:title" content="Developer plans massive warehouse for retail overstock in Batavia business park" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.thebatavian.com/howard-b-owens/developer-plans-massive-warehouse-for-retail-overstock-in-batavia-business-park" />
<meta property="og:description" content="Mega Properties is planning another massive warehouse for the Gateway II industrial park east of Route 98 in the Town of Batavia. This time it will be a 200,000 square-foot warehouse available for area retailers to store inventory overstock. Lucas Bushen, with Marathon Engineering, presented initial plans to the town planning board on Tuesday. He said there will be few employees at the warehouse at any one time, so only about 20 parking spaces will be needed. A full environmental review is required for the building, and the planning board approved a resolution to be the lead agency on the review. The 22-acre parcel is off of Call Parkway. It will be a Butler Building with typical remanufactured metal building elements: concrete foundation, metal siding, and sloped roof. The building will be constructed in phases with Phase One including 71,000 square feet of warehouse space and 3,200 square feet of office space. There are two ponds on the property. In order to construct the building, one of the ponds will be relocated. There are also two federally designated wetlands on the property. The wetlands will not be disturbed. Mega Properties intends to invest more than $3 million into the project. Mega Properties has long-standing ties to Batavia, having launched in Batavia’s Harvester Business Incubation Center more than 30 years ago. The business is currently based at the Gateway I Corporate Park in the Town of Batavia. In 2020, just prior to the start of the pandemic, Mega Properties sought financial assistance from GCEDC for the project. At the time, they were seeking approximately $558,497 in assistance, including a property tax exemption of $400,497, a sales tax exemption of $128,000, and a mortgage tax exemption of $30,000. There was a public hearing on the request but the application did not go any further because of the disruption of the pandemic. No announcement has been made yet on when the GCEDC board will next take up the application. Top photo: Lucas Bushen presents plans for a warehouse off of Call Parkway in the Town of Batavia to the town&#039;s planning board. Photo by Howard Owens. Below, drawings of the project from planning documents." />
<meta property="og:updated_time" content="2022-05-18T15:53:34-04:00" />
<meta property="og:image" content="https://www.thebatavian.com/files/users/60/2022-05/lucasbushenplanning2022.jpg" />
<meta property="og:image" content="https://www.thebatavian.com/files/users/60/2022-05/conceptialwarehousemega2022.jpg" />
<meta property="og:image" content="https://www.thebatavian.com/files/users/60/2022-05/conceptialwarehousemega20222.jpg" />
<meta property="og:image" content="https://www.thebatavian.com/sites/all/modules/features/site_batavian/batavian.png" />
<meta property="og:image:secure_url" content="https://www.thebatavian.com/files/users/60/2022-05/lucasbushenplanning2022.jpg" />
<meta property="og:image:secure_url" content="https://www.thebatavian.com/files/users/60/2022-05/conceptialwarehousemega2022.jpg" />
<meta property="og:image:secure_url" content="https://www.thebatavian.com/files/users/60/2022-05/conceptialwarehousemega20222.jpg" />
<meta property="og:image:secure_url" content="https://www.thebatavian.com/sites/all/modules/features/site_batavian/batavian.png" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:site" content="@thebatavian" />
<meta name="twitter:creator" content="@thebatavian" />
<meta name="twitter:title" content="Developer plans massive warehouse for retail overstock in Batavia" />
<meta name="twitter:url" content="https://www.thebatavian.com/howard-b-owens/developer-plans-massive-warehouse-for-retail-overstock-in-batavia-business-park" />
<meta name="twitter:description" content="Mega Properties is planning another massive warehouse for the Gateway II industrial park east of Route 98 in the Town of Batavia. This time it will be a 200,000 square-foot warehouse available for" />
<meta name="twitter:image" content="https://www.thebatavian.com/files/users/60/2022-05/lucasbushenplanning2022.jpg" />
<meta property="article:publisher" content="https://www.facebook.com/thebatavian" />
<meta property="article:tag" content="Mega Properties" />
<meta property="article:tag" content="batavia" />
<meta property="article:tag" content="news" />
<meta property="article:tag" content="Gateway II" />
<meta property="article:published_time" content="2022-05-18T15:50:00-04:00" />
<meta property="article:modified_time" content="2022-05-18T15:53:34-04:00" />
<meta name="dcterms.title" content="Developer plans massive warehouse for retail overstock in Batavia business park" />
<meta name="dcterms.creator" content="Howard B. Owens" />
<meta name="dcterms.description" content="Mega Properties is planning another massive warehouse for the Gateway II industrial park east of Route 98 in the Town of Batavia. This time it will be a 200,000 square-foot warehouse available for area retailers to store inventory overstock. Lucas Bushen, with Marathon Engineering, presented initial plans to the town planning board on Tuesday. He said there will be few employees at the warehouse at any one time, so only about 20 parking spaces will be needed. A full environmental review is required for the building, and the planning board approved a resolution to be the lead agency on the review. The 22-acre parcel is off of Call Parkway. It will be a Butler Building with typical remanufactured metal building elements: concrete foundation, metal siding, and sloped roof. The building will be constructed in phases with Phase One including 71,000 square feet of warehouse space and 3,200 square feet of office space. There are two ponds on the property. In order to construct the building, one of the ponds will be relocated. There are also two federally designated wetlands on the property. The wetlands will not be disturbed. Mega Properties intends to invest more than $3 million into the project. Mega Properties has long-standing ties to Batavia, having launched in Batavia’s Harvester Business Incubation Center more than 30 years ago. The business is currently based at the Gateway I Corporate Park in the Town of Batavia. In 2020, just prior to the start of the pandemic, Mega Properties sought financial assistance from GCEDC for the project. At the time, they were seeking approximately $558,497 in assistance, including a property tax exemption of $400,497, a sales tax exemption of $128,000, and a mortgage tax exemption of $30,000. There was a public hearing on the request but the application did not go any further because of the disruption of the pandemic. No announcement has been made yet on when the GCEDC board will next take up the application. Top photo: Lucas Bushen presents plans for a warehouse off of Call Parkway in the Town of Batavia to the town&#039;s planning board. Photo by Howard Owens. Below, drawings of the project from planning documents." />
<meta name="dcterms.date" content="2022-05-18T15:50-04:00" />
<meta name="dcterms.type" content="Text" />
<meta name="dcterms.format" content="text/html" />
<meta name="dcterms.identifier" content="https://www.thebatavian.com/howard-b-owens/developer-plans-massive-warehouse-for-retail-overstock-in-batavia-business-park" />
<link type="text/css" rel="stylesheet" href="/files/advagg_css/css__LdCcL6EdFRY_vtrda6apFmz82_7y__e2knkpe_gWn7k__VecF3kbBcRD0cCpq__LFEEpSn9Chp3w2shbBaBoP5Ug__ZE1YzrmRrq78kDV5aH_1eaOISSctoCO7FJtBucbLSKE.css" media="all" />
<link type="text/css" rel="stylesheet" href="/files/advagg_css/css__UqcW5aRBpyv9mYp--Lb4XPcG9siu5UGE9sNupJU1n5E__GLhtBaJzzzCnL8cdHMo593WCqIXMJiEgUPE4_ftA5TA__ZE1YzrmRrq78kDV5aH_1eaOISSctoCO7FJtBucbLSKE.css" media="print" />
<!--[if lte IE 8]>
<link type="text/css" rel="stylesheet" href="/files/advagg_css/css__1-jkVT27AjTIEc7RQZ_tNMScVUqhP653iLGt9cb3hvA__xTGCWPLzcZANNWCd1_ltn8bxY9ceQfK1J4wJldTx2x8__ZE1YzrmRrq78kDV5aH_1eaOISSctoCO7FJtBucbLSKE.css" media="all" />
<![endif]-->
<script type="text/javascript" src="/files/advagg_js/js__6klYbmt_F4_48YoD14kHrFHdMyz3VgvqCRrCy7rc_p0__Fy8ok8AQJ0VsVt2wiDe-z09uiECtrbw2P1PITxqK78A__ZE1YzrmRrq78kDV5aH_1eaOISSctoCO7FJtBucbLSKE.js"></script>
<!--[if (gte IE 6)&(lte IE 8)]>
<script type="text/javascript" src="/files/advagg_js/js__ZUioMY4Endyj2YQ4nhQ0Oc7LQkgBC0vXfP9Pk1q-CYU__vFC-mxdyFZP7cYtMjHj1-wjzi8j929dCXx0NxwDhNbA__ZE1YzrmRrq78kDV5aH_1eaOISSctoCO7FJtBucbLSKE.js"></script>
<![endif]-->
<script type="text/javascript" src="/files/advagg_js/js__KaZp60twaRFpB7IdN57N22C_sjMQDY1aEnvERtknlIg__1heMEGpuuHZnihe04BOr3X2vIc8bRMaEUwDqgCjyFsM__ZE1YzrmRrq78kDV5aH_1eaOISSctoCO7FJtBucbLSKE.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
(function(i,s,o,g,r,a,m){i["GoogleAnalyticsObject"]=r;i[r]=i[r]||function(){(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)})(window,document,"script","https://www.thebatavian.com/files/googleanalytics/analytics.js?rb1rdp","ga");ga("create", "UA-1245005-9", {"cookieDomain":"auto"});ga("send", "pageview");
//--><!]]>
</script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
(function(d) {
  var el, fjs = d.getElementsByTagName('script')[0];
  el = d.createElement('script');
  el.id = 'js-pp-banner';
  el.src = '//dashboard.presspatron.com/dev/banner?b=suwonanV8g4xHnSQHQ98FXe5';
  fjs.parentNode.insertBefore(el, fjs);
}(document));
//--><!]]>
</script>
<script type="text/javascript" src="/files/advagg_js/js__sjuwKgveUDRjQcepijK1UbRGU5wWykpFv3hESrZN-f0__gdKk0rJKZ-_FIMgbRx4VrAIzndU3XwIWNqvAc6BOx5I__ZE1YzrmRrq78kDV5aH_1eaOISSctoCO7FJtBucbLSKE.js"></script>
<script type="text/javascript" src="/files/advagg_js/js__syMgLnDB3_p6QkkgHxtikG3IbZHKzhhN5G_4a83J3Bk__-1t5961TgnE_5xyoH94I-2uJhzvvHxKqcr6iptnGtjY__ZE1YzrmRrq78kDV5aH_1eaOISSctoCO7FJtBucbLSKE.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
jQuery.extend(Drupal.settings, {"basePath":"\/","pathPrefix":"","video_filter":{"url":{"ckeditor":"\/video_filter\/dashboard\/ckeditor"},"instructions_url":"\/video_filter\/instructions","modulepath":"sites\/all\/modules\/contrib\/video_filter"},"googleanalytics":{"trackOutbound":1,"trackMailto":1,"trackDownload":1,"trackDownloadExtensions":"7z|aac|arc|arj|asf|asx|avi|bin|csv|doc(x|m)?|dot(x|m)?|exe|flv|gif|gz|gzip|hqx|jar|jpe?g|js|mp(2|3|4|e?g)|mov(ie)?|msi|msp|pdf|phps|png|ppt(x|m)?|pot(x|m)?|pps(x|m)?|ppam|sld(x|m)?|thmx|qtm?|ra(m|r)?|sea|sit|tar|tgz|torrent|txt|wav|wma|wmv|wpd|xls(x|m|b)?|xlt(x|m)|xlam|xml|z|zip"},"saveguard":{"msg":null},"urlIsAjaxTrusted":{"\/howard-b-owens\/developer-plans-massive-warehouse-for-retail-overstock-in-batavia-business-park":true,"\/":true},"broadstreet_ads":{"zones":[1246,1263,1261,1248,39917,1255,1267,53093,1253,1266,23893,1252,1265,1250,1244,1243,1264,1945,82176,1258,1949,1257,40855,1262,1251,1256,1245,1249],"b_option":"","add_body_class":"noads"},"ajaxPageState":{"js":{"sites\/all\/modules\/contrib\/addthis\/addthis.js":1,"misc\/jquery.js":1,"misc\/jquery-extend-3.4.0.js":1,"misc\/jquery-html-prefilter-3.5.0-backport.js":1,"misc\/jquery.once.js":1,"misc\/drupal.js":1,"sites\/all\/themes\/omega\/omega\/js\/no-js.js":1,"sites\/all\/themes\/omega_batavian\/libraries\/html5shiv\/html5shiv.min.js":1,"sites\/all\/themes\/omega_batavian\/libraries\/html5shiv\/html5shiv-printshiv.min.js":1,"sites\/all\/themes\/omega_batavian\/libraries\/respond\/respond.min.js":1,"sites\/all\/modules\/contrib\/google_analytics\/googleanalytics.js":1,"sites\/all\/modules\/contrib\/saveguard\/saveguard.js":1,"sites\/all\/modules\/contrib\/broadstreet_ads\/blockers.js":1,"sites\/all\/themes\/omega_batavian\/js\/omega-batavian.behaviors.js":1}}});
//--><!]]>
</script>
<script data-ad-client="ca-pub-8468909626695267" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
(function(w, d) {
 w.adthrive = w.adthrive || {};
 w.adthrive.cmd = w.adthrive.cmd || [];
 w.adthrive.plugin = 'adthrive-ads-manual';
 w.adthrive.host = 'ads.adthrive.com';

 var s = d.createElement('script');
 s.async = true;
 s.referrerpolicy='no-referrer-when-downgrade';
 s.src = 'https://' + w.adthrive.host + '/sites/61e1c3c6d3957b001cf2f244/ads.min.js?referrer=' + w.encodeURIComponent(w.location.href) + '&cb=' + (Math.floor(Math.random() * 100) + 1);
 var n = d.getElementsByTagName('script')[0];
 n.parentNode.insertBefore(s, n);
})(window, document);
</script>
</head>
<body class="html not-front not-logged-in page-node page-node- page-node-605553 node-type-blog node-promoted page-display-default section-howard-b-owens">
<script type="text/javascript">
<!--//--><![CDATA[//><!--
  var _qevents = _qevents || [];
  (function() {
    var elem = document.createElement('script');
    elem.src = (document.location.protocol == "https:" ? "https://secure" : "http://edge") + ".quantserve.com/quant.js";
    elem.async = true;
    elem.type = "text/javascript";
    var scpt = document.getElementsByTagName('script')[0];
    scpt.parentNode.insertBefore(elem, scpt);
  })();
  _qevents.push({"qacct":"p-72c3g5HZgroR-"});
//--><!]]>
</script>
<noscript>
  <div style="display:none;"><img src="//pixel.quantserve.com/pixel/p-72c3g5HZgroR-.gif" height="1" width="1" alt="Quantcast"/></div>
</noscript>
<div id="pp-banner"></div>
<div class="panel-display page-layout-threecol clear-block">
<div class="panel-panel panel-col-page-prefix clearfix">
<div class="inside clearfix"><div class="panel-pane pane-ad pane-1243 broadstreet-ad broadstreet-1243">
<script type="text/javascript">if (typeof broadstreet !== 'undefined') broadstreet.zone(1243);</script>
</div>
<div class="panel-pane pane-ad pane-1264 broadstreet-ad broadstreet-1264">
<script type="text/javascript">if (typeof broadstreet !== 'undefined') broadstreet.zone(1264);</script>
</div>
</div>
</div>
<div class="page-wrapper">
<header>
<div class="panel-panel panel-col-header-prefix clearfix">
<div class="inside"><div class="panel-pane pane-block pane-menu-secondary-menu">
<ul class="menu"><li class="first leaf"><a href="https://www.thebatavian.com/bowling" title="">Pin Points</a></li>
<li class="leaf"><a href="http://bataviaslist.com/calendar/" title="">Calendar</a></li>
<li class="leaf"><a href="/36453/contact-us" title="Contact Us">Contact Us</a></li>
<li class="leaf"><a href="https://advertising.thebatavian.com/" title="Page about advertising on the site.">Advertise</a></li>
<li class="last leaf"><a href="/1917/about-batavian" title="">About</a></li>
</ul> </div>
</div>
</div>
<div class="panel-panel panel-col-header clearfix">
<div class="inside"><div class="panel-pane pane-page-logo">
<a href="/" rel="home" id="logo" title="Home"><img src="https://www.thebatavian.com/files/thebatavian_logo.png" alt="Home" /></a> </div>
<div class="panel-pane pane-search-api-page-search-box">
<form class="search-api-page-search-form-content" action="/howard-b-owens/developer-plans-massive-warehouse-for-retail-overstock-in-batavia-business-park" method="post" id="search-api-page-search-form-content" accept-charset="UTF-8"><div><div class="form-item form-type-textfield form-item-keys-1">
<label class="element-invisible" for="edit-keys-1">Enter your keywords </label>
<input placeholder="Enter your keywords" type="text" id="edit-keys-1" name="keys_1" value="" size="15" maxlength="128" class="form-text" />
</div>
<input type="hidden" name="id" value="1" />
<input type="submit" id="edit-submit-1" name="op" value="Search" class="form-submit" /><input type="hidden" name="form_build_id" value="form-TzxeY39o-bKZh2b9tq4EcFZL2Lh_YwmjBnULervpq7A" />
<input type="hidden" name="form_id" value="search_api_page_search_form_content" />
</div></form> </div>
<div class="panel-pane pane-page-slogan">
Local Matters </div>
</div>
</div>
<div class="panel-panel panel-col-header-suffix clearfix">
<div class="inside"><div class="panel-pane pane-ad pane-1246 broadstreet-ad broadstreet-1246">
<script type="text/javascript">if (typeof broadstreet !== 'undefined') broadstreet.zone(1246);</script>
</div>
<div class="panel-pane pane-ad pane-1263 broadstreet-ad broadstreet-1263">
<script type="text/javascript">if (typeof broadstreet !== 'undefined') broadstreet.zone(1263);</script>
</div>
<div class="panel-pane pane-ad pane-1261 broadstreet-ad broadstreet-1261">
<script type="text/javascript">if (typeof broadstreet !== 'undefined') broadstreet.zone(1261);</script>
</div>
</div>
</div>
</header>
<div class="panel-panel panel-col-navigation clearfix">
<div class="inside"><div class="panel-pane pane-block pane-system-main-menu">
<ul class="menu"><li class="first leaf"><a href="/" title="">Home</a></li>
<li class="leaf"><a href="http://bataviaslist.com/" title="">Batavia&#039;s List</a></li>
<li class="leaf"><a href="https://bataviaslist.com/calendar/#/" title="">Calendar</a></li>
<li class="leaf"><a href="http://shoplocal.thebatavian.com" title="">Shop Local</a></li>
<li class="leaf"><a href="/sports" title="Sports">Sports</a></li>
<li class="leaf"><a href="/business" title="News of local business">Business</a></li>
<li class="leaf"><a href="/announcements" title="">Announcements</a></li>
<li class="leaf"><a href="/obituaries" title="">Obituaries</a></li>
<li class="leaf"><a href="http://bataviaslist.com/listings/browse-categories/9/employment/" title="">Jobs</a></li>
<li class="last leaf"><a href="http://bataviaslist.com/listings/browse-categories/4/real-estate-and-housing/" title="">Housing</a></li>
</ul> </div>
</div>
</div>
<div class="center-wrapper clearfix">
<div class="panel-panel page-col-first">
<div class="inside"><div class="panel-pane pane-ad pane-1248 broadstreet-ad broadstreet-1248">
<script type="text/javascript">if (typeof broadstreet !== 'undefined') broadstreet.zone(1248);</script>
</div>
<div class="panel-pane pane-ad pane-39917 broadstreet-ad broadstreet-39917">
<script type="text/javascript">if (typeof broadstreet !== 'undefined') broadstreet.zone(39917);</script>
</div>
<div class="panel-pane pane-custom pane-1">
<p>&gt;&gt; Download &lt;&lt;<br /><a href="https://itunes.apple.com/us/app/the-batavian/id1232469082?mt=8&amp;ign-mpt=uo%3D4" target="_blank">New iOS App</a><br /><a href="https://play.google.com/store/apps/details?id=com.thebatavian.mobile.thebatavian" target="_blank">New Android App</a></p>
</div>
<div class="panel-pane pane-block pane-user-login">
<h2 class="pane-title">User login</h2>
<form class="user-login-form" action="/" method="post" id="user-login-form" accept-charset="UTF-8"><div><div class="form-item form-type-textfield form-item-name">
<label for="edit-name">E-mail or username <span class="form-required" title="This field is required.">*</span></label>
<input type="text" id="edit-name" name="name" value="" size="15" maxlength="60" class="form-text required" />
</div>
<div class="form-item form-type-password form-item-pass">
<label for="edit-pass">Password <span class="form-required" title="This field is required.">*</span></label>
<input type="password" id="edit-pass" name="pass" size="15" maxlength="128" class="form-text required" />
</div>
<ul><li><a href="/user/register" title="Create a new user account.">Create new account</a></li>
<li><a href="/user/password" title="Request new password via e-mail.">Request new password</a></li>
</ul><input type="hidden" name="form_build_id" value="form-exMURRaj1_pL-UW0DgLXMGx-3CJuGLE6VYf9jF1vYUo" />
<input type="hidden" name="form_id" value="user_login_block" />
<div class="form-actions form-wrapper" id="edit-actions"><input type="submit" id="edit-submit" name="op" value="Log in" class="form-submit" /></div></div></form> </div>
<div class="panel-pane pane-ad pane-1255 broadstreet-ad broadstreet-1255">
<script type="text/javascript">if (typeof broadstreet !== 'undefined') broadstreet.zone(1255);</script>
</div>
<div class="panel-pane pane-block pane-menu-menu-genseecountytowns">
<h2 class="pane-title">Our Towns</h2>
<ul class="menu"><li class="first leaf"><a href="/alabama" title="">Alabama</a></li>
<li class="leaf"><a href="/alexander" title="">Alexander</a></li>
<li class="leaf"><a href="/batavia" title="">Batavia</a></li>
<li class="leaf"><a href="/bergen" title="">Bergen</a></li>
<li class="leaf"><a href="/bethany" title="">Bethany</a></li>
<li class="leaf"><a href="/byron" title="">Byron</a></li>
<li class="leaf"><a href="/corfu" title="">Corfu</a></li>
<li class="leaf"><a href="/darien" title="">Darien</a></li>
<li class="leaf"><a href="/elba" title="">Elba</a></li>
<li class="leaf"><a href="/oakfield" title="">Oakfield</a></li>
<li class="leaf"><a href="/pavilion" title="">Pavilion</a></li>
<li class="leaf"><a href="/pembroke" title="">Pembroke</a></li>
<li class="last leaf"><a href="/stafford" title="">Stafford</a></li>
</ul> </div>
<div class="panel-pane pane-ad pane-1267 broadstreet-ad broadstreet-1267">
<script type="text/javascript">if (typeof broadstreet !== 'undefined') broadstreet.zone(1267);</script>
</div>
<div class="panel-pane pane-block pane-broadstreet-ads-53093">
<script type="text/javascript">if (typeof broadstreet !== 'undefined') broadstreet.zone(53093);</script>
</div>
<div class="panel-pane pane-ad pane-1253 broadstreet-ad broadstreet-1253">
<script type="text/javascript">if (typeof broadstreet !== 'undefined') broadstreet.zone(1253);</script>
</div>
<div class="panel-pane pane-ad pane-1266 broadstreet-ad broadstreet-1266">
<script type="text/javascript">if (typeof broadstreet !== 'undefined') broadstreet.zone(1266);</script>
</div>
<div class="panel-pane pane-ad pane-23893 broadstreet-ad broadstreet-23893">
<script type="text/javascript">if (typeof broadstreet !== 'undefined') broadstreet.zone(23893);</script>
</div>
<div class="panel-pane pane-views pane-comments-all-recent">
<h2 class="pane-title">Recent comments</h2>
<div class="view view-comments-all-recent view-id-comments_all_recent view-display-id-default view-dom-id-6aac6aff112d375097a1f9e182055b50">
<div class="view-content">
<div class="item-list"><ul> <li class="views-row views-row-1 views-row-odd views-row-first">
<div class="views-field views-field-subject"> <span class="field-content"><a href="/comment/103428#comment-103428">Roundabouts reduce the risk</a></span> </div>
<div class="views-field views-field-name-1"> <span class="views-label views-label-name-1">by: </span> <span class="field-content"><span class="username">Scott Batson</span></span> </div></li>
<li class="views-row views-row-2 views-row-even">
<div class="views-field views-field-subject"> <span class="field-content"><a href="/comment/103427#comment-103427">I like this a lot.</a></span> </div>
<div class="views-field views-field-name-1"> <span class="views-label views-label-name-1">by: </span> <span class="field-content"><span class="username">Michael DePumpo</span></span> </div></li>
<li class="views-row views-row-3 views-row-odd">
<div class="views-field views-field-subject"> <span class="field-content"><a href="/comment/103426#comment-103426">Vote NO</a></span> </div>
<div class="views-field views-field-name-1"> <span class="views-label views-label-name-1">by: </span> <span class="field-content"><span class="username">John Roach</span></span> </div></li>
<li class="views-row views-row-4 views-row-even">
<div class="views-field views-field-subject"> <span class="field-content"><a href="/comment/103425#comment-103425">2.7 million spending increase</a></span> </div>
<div class="views-field views-field-name-1"> <span class="views-label views-label-name-1">by: </span> <span class="field-content"><span class="username">Mark Potwora</span></span> </div></li>
<li class="views-row views-row-5 views-row-odd">
<div class="views-field views-field-subject"> <span class="field-content"><a href="/comment/103424#comment-103424">Steve, Get yourself a couple</a></span> </div>
<div class="views-field views-field-name-1"> <span class="views-label views-label-name-1">by: </span> <span class="field-content"><span class="username">david spaulding</span></span> </div></li>
<li class="views-row views-row-6 views-row-even">
<div class="views-field views-field-subject"> <span class="field-content"><a href="/comment/103423#comment-103423">Please remember that</a></span> </div>
<div class="views-field views-field-name-1"> <span class="views-label views-label-name-1">by: </span> <span class="field-content"><span class="username">John Roach</span></span> </div></li>
<li class="views-row views-row-7 views-row-odd">
<div class="views-field views-field-subject"> <span class="field-content"><a href="/comment/103422#comment-103422">Ever the partisan</a></span> </div>
<div class="views-field views-field-name-1"> <span class="views-label views-label-name-1">by: </span> <span class="field-content"><span class="username">C. M. Barons</span></span> </div></li>
<li class="views-row views-row-8 views-row-even">
<div class="views-field views-field-subject"> <span class="field-content"><a href="/comment/103421#comment-103421">There is no employment</a></span> </div>
<div class="views-field views-field-name-1"> <span class="views-label views-label-name-1">by: </span> <span class="field-content"><span class="username">John Roach</span></span> </div></li>
<li class="views-row views-row-9 views-row-odd">
<div class="views-field views-field-subject"> <span class="field-content"><a href="/comment/103420#comment-103420">hmmmm didn&#039;t even make it a</a></span> </div>
<div class="views-field views-field-name-1"> <span class="views-label views-label-name-1">by: </span> <span class="field-content"><span class="username">Mark Potwora</span></span> </div></li>
<li class="views-row views-row-10 views-row-even views-row-last">
<div class="views-field views-field-subject"> <span class="field-content"><a href="/comment/103419#comment-103419">Regular, menthol, filtered,</a></span> </div>
<div class="views-field views-field-name-1"> <span class="views-label views-label-name-1">by: </span> <span class="field-content"><span class="username">david spaulding</span></span> </div></li>
</ul></div> </div>
</div> </div>
<div class="panel-pane pane-ad pane-1252 broadstreet-ad broadstreet-1252">
<script type="text/javascript">if (typeof broadstreet !== 'undefined') broadstreet.zone(1252);</script>
</div>
<div class="panel-pane pane-ad pane-1265 broadstreet-ad broadstreet-1265">
<script type="text/javascript">if (typeof broadstreet !== 'undefined') broadstreet.zone(1265);</script>
</div>
<div class="panel-pane pane-ad pane-1250 broadstreet-ad broadstreet-1250">
<script type="text/javascript">if (typeof broadstreet !== 'undefined') broadstreet.zone(1250);</script>
</div>
<div class="panel-pane pane-block pane-menu-menu-sponsors">
<h2 class="pane-title">Community Sponsors</h2>
<ul class="menu"><li class="first leaf"><a href="http://www.adammillertoyandbicycle.com/" target="_blank">Adam Miller Toy and Bicycle</a></li>
<li class="leaf"><a href="http://www.advancedpodiatryassociates.com" title="">Advanced Podiatry Associates</a></li>
<li class="leaf"><a href="https://www.facebook.com/alabamahotelbasom/" title="">Alabama Hotel</a></li>
<li class="leaf"><a href="http://www.alexsribs.com/">Alex&#039;s Place</a></li>
<li class="leaf"><a href="https://www.alleghanyfarmservices.com" title="">Alleghany Farm Services</a></li>
<li class="leaf"><a href="https://www.facebook.com/Angry-Charlies-smokehouse-BBQ-106791614394699" title="">Angry Charlie&#039;s Smokehouse BBQ</a></li>
<li class="leaf"><span title="" class="nolink" tabindex="0">A Place for Change - Joan Liggetto</span></li>
<li class="leaf"><a href="http://www.bataviaassemblyofgod.com" title="">Batavia Assembly of God Church</a></li>
<li class="leaf"><a href="http://www.bataviacc.com" title="">Batavia Country Club</a></li>
<li class="leaf"><a href="http://www.bataviadownscasino.com/">Batavia Downs</a></li>
<li class="leaf"><a href="https://www.facebook.com/BataviasOriginal/" title="">Batavia&#039;s Original</a></li>
<li class="leaf"><span title="" class="nolink" tabindex="0">Batavia Redemption Center, Eastown Beverages</span></li>
<li class="leaf"><a href="http://www.beds-n-bones.com/">Beds &#039;n&#039; Bones Pet Lodge</a></li>
<li class="leaf"><span class="nolink" tabindex="0">Bill Fox and Son Construction &amp; Remodeling</span></li>
<li class="leaf"><a href="http://www.bontragerauction.com/">Bontrager&#039;s Real Estate</a></li>
<li class="leaf"><a href="http://www.bourbonandburger.com/#!" title="">Bourbon &amp; Burger Co.</a></li>
<li class="leaf"><a href="https://www.facebook.com/Byron-Holley-Self-Storage-111605074762791" title="">Byron Holley Self Storage</a></li>
<li class="leaf"><a href="http://www.bubbaslandscape.net" title="">Bubba&#039;s Landscaping</a></li>
<li class="leaf"><a href="https://www.facebook.com/pages/category/Funeral-Service---Cemetery/C-B-Beach-Son-Mortuary-158778817487912/" title="">CB Beach Mortuary</a></li>
<li class="leaf"><a href="http://www.cedarstreetonline.com/">Cedar St. Sales and Rentals</a></li>
<li class="leaf"><a href="https://chapinmfg.com" title="">Chapin</a></li>
<li class="leaf"><a href="https://www.facebook.com/ChapsElbaDiner?fref=ts" title="">Chap&#039;s Elba Diner &amp; Catering</a></li>
<li class="leaf"><a href="https://cinquinospizza.com" title="">Cinquino&#039;s Pizza</a></li>
<li class="leaf"><a href="https://thecitychurch.com" title="">City Church</a></li>
<li class="leaf"><a href="http://www.classicopticalbatavia.com/" title="">Classic Optical</a></li>
<li class="leaf"><a href="https://www.facebook.com/thecoffeepress13/" title="">The Coffee Press</a></li>
<li class="leaf"><a href="http://caoginc.org" title="">Community Action of Orleans and Genesee</a></li>
<li class="leaf"><a href="http://www.councilbatavia.com/">Council Opticians</a></li>
<li class="leaf"><a href="http://www.crazycheapcars.com/">Crazy Cheap Cars</a></li>
<li class="leaf"><a href="http://danstire.com/">Dan&#039;s Tire</a></li>
<li class="leaf"><a href="http://www.dandrdepot.com/">D&amp;R Depot Restaurant</a></li>
<li class="leaf"><a href="https://www.facebook.com/pages/Daves-Ice-Cream/538860869467311" title="">Dave&#039;s Ice Cream</a></li>
<li class="leaf"><a href="http://www.deepbluepoolandspa.com/">Deep Blue Pool &amp; Spa</a></li>
<li class="leaf"><a href="http://www.dolcepanepinto.com" title="">Dolce Panepinto Attorneys At Law</a></li>
<li class="leaf"><a href="http://www.dumbleton.com" title="">Dumbleton&#039;s Used Auto Parts</a></li>
<li class="leaf"><a href="https://www.facebook.com/BataviaEden/" title="">Eden Cafe &amp; Bakeshop</a></li>
<li class="leaf"><a href="https://elifishbrewing.com" title="">Eli Fish Brewing Co.</a></li>
<li class="leaf"><a href="http://www.erieeast.com" title="">Erie East Windows &amp; Doors</a></li>
<li class="leaf"><a href="http://www.falconefuneralhome.com/">Falcone Family Funeral &amp; Cremation Service Inc.</a></li>
<li class="leaf"><a href="http://www.fastecautomotive.com/">Fastec Automotive</a></li>
<li class="leaf"><a href="http://www.powdercoattoday.com">The Finishing Line</a></li>
<li class="leaf"><a href="http://stores.ebay.com/FOXPROWL" title="">Foxprowl Collectables</a></li>
<li class="leaf"><a href="https://www.bakersfrontierkitchens.com" title="">Frontier Kitchen</a></li>
<li class="leaf"><a href="https://www.facebook.com/geneseecouncil/" title="">GCASA</a></li>
<li class="leaf"><a href="https://www.genesee.edu" title="">Genesee Community College</a></li>
<li class="leaf"><a href="http://www.geneseedental.com/">Genesee Dental Group</a></li>
<li class="leaf"><a href="https://jobs.kochcareers.com/search/georgia-pacific/jobs" title="">Georgia Pacific - Batavia</a></li>
<li class="leaf"><a href="http://www.geracerealty.com" title="">Gerace Realty - Robert J. Gerace</a></li>
<li class="leaf"><a href="https://www.gsoptics.com" title="">Germanow-Simon Corporation | G-S Plastic Optics</a></li>
<li class="leaf"><a href="https://www.facebook.com/gillianasdiner" title="">Gilliana&#039;s Diner</a></li>
<li class="leaf"><a href="http://www.gilmartinfuneralhome.com/" title="">Gilmartin Funeral Home &amp; Cremation Company, Inc.</a></li>
<li class="leaf"><a href="http://www.godfreyspond.org/">Godfrey&#039;s Pond</a></li>
<li class="leaf"><a href="http://www.hairstudio25.com/">Hair Studio 25</a></li>
<li class="leaf"><a href="http://www.bataviafuneralhomes.com/">H.E. Turner &amp; Co.</a></li>
<li class="leaf"><a href="http://www.harriswilcox.com/home/" title="">Harris Wilcox Inc.</a></li>
<li class="leaf"><a href="http://www.haul-4-less.com/">Haul-4-Less</a></li>
<li class="leaf"><a href="http://henryhcook.com" title="">Henry H. Cook Inc.</a></li>
<li class="leaf"><a href="https://www.facebook.com/High-Voltage-Body-Art-Piercing-113959858653297" title="">High Voltage Tattoo</a></li>
<li class="leaf"><a href="http://www.johnsstudio.com" title="">Hodgins Printing</a></li>
<li class="leaf"><a href="https://michelledills.howardhanna.com" title="">Howard Hanna - Michelle Dills</a></li>
<li class="leaf"><a href="http://www.htpartners.net/">Humphrey&#039;s Electric &amp; Security</a></li>
<li class="leaf"><a href="https://www.facebook.com/mariescofield.howardhanna" title="">Hunt Real Estate - Marie Scofield</a></li>
<li class="leaf"><a href="https://www.facebook.com/IslandsHawaiianGrill/" title="">Islands Hawaiian Grill</a></li>
<li class="leaf"><a href="https://www.jatrny.com" title="">Jam at the Ridge</a></li>
<li class="leaf"><a href="http://www.mcandrewfuneralhomes.net/">J. Leonard McAndrew</a></li>
<li class="leaf"><a href="https://www.facebook.com/pages/Jagged-Edges-Salon/117143028365903" title="">Jagged Edges Salon</a></li>
<li class="leaf"><a href="https://www.facebook.com/pages/Johns-Service-Station/161992880491018" title="">John&#039;s Service Station</a></li>
<li class="leaf"><a href="http://www.kenbarrett.com/">Ken Barrett</a></li>
<li class="leaf"><a href="http://www.kreativedesignkitchenandbath.com/">Kreative Design Kitchen &amp; Bath</a></li>
<li class="leaf"><a href="http://www.landltransmissions.com/">L&amp;L Transmission, Inc.</a></li>
<li class="leaf"><a href="http://www.libertypumps.com" title="">Liberty Pumps</a></li>
<li class="leaf"><a href="https://www.facebook.com/liviabeautyspa/?hc_ref=SEARCH&amp;fref=nf" title="">Livia Beauty &amp; Spa</a></li>
<li class="leaf"><a href="https://www.facebook.com/mamachaveztaqueria/" title="">Mama Chavez&#039;s Taqueria</a></li>
<li class="leaf"><span class="nolink" tabindex="0">Matteo &amp; Mullen, CPA</span></li>
<li class="leaf"><a href="http://www.maxpiesfurniture.com/">Max Pies</a></li>
<li class="leaf"><a href="https://www.facebook.com/Nortons-Chizzelwood-554294357923961" title="">Norton&#039;s Chizzelwood</a></li>
<li class="leaf"><a href="https://www.facebook.com/OLACYSIRISHPUB" title="">O&#039;Lacy&#039;s Irish Pub</a></li>
<li class="leaf"><a href="http://www.oakfieldfitness.com/">Oakfield Fitness</a></li>
<li class="leaf"><a href="http://oliverscandies.com/">Oliver&#039;s Candies</a></li>
<li class="leaf"><span class="nolink" tabindex="0">Optique</span></li>
<li class="leaf"><a href="http://www.ficarellaspizzaleroy.com" title="">Pastore&#039;s Pizzeria</a></li>
<li class="leaf"><a href="http://www.pellegrinoautosales.com/">Pellegrino Auto Sales</a></li>
<li class="leaf"><a href="https://www.thebatavian.com/bowling" title="">Pin Points</a></li>
<li class="leaf"><a href="http://www.riderrealestate.com" title="">Rider Real Estate</a></li>
<li class="leaf"><a href="https://www.rochesterregional.org/locations/hospitals/united-memorial-medical-center" title="">Rochester Regional Health – UMMC</a></li>
<li class="leaf"><a href="https://www.romansonmain.com" title="">Roman&#039;s</a></li>
<li class="leaf"><a href="http://sallomehvac.com" title="">Sallome Heating &amp; Cooling</a></li>
<li class="leaf"><a href="https://www.zmenu.com/santinos-pizza-oakfield-online-menu/" title="">Santino&#039;s Pizza</a></li>
<li class="leaf"><a href="https://schultzauctioneers.net" title="">Schultz Auctioneers</a></li>
<li class="leaf"><a href="http://www.selectcollisionny.com" title="">Select Collision</a></li>
<li class="leaf"><a href="http://www.settlersrestaurant.com/">Settler&#039;s Restaurant</a></li>
<li class="leaf"><a href="http://www.skylinervresort.com" title="">Skyline RV Sales &amp; Service</a></li>
<li class="leaf"><span class="nolink" tabindex="0">Sloat&#039;s Tire</span></li>
<li class="leaf"><a href="http://www.smartdesignarchitecture.com" title="">Smart Design Architecture</a></li>
<li class="leaf"><a href="https://www.facebook.com/pages/Smokin-Eagle-BBQ/171066096336858?fref=ts" title="">Smokin&#039; Eagle BBQ and Brew</a></li>
<li class="leaf"><a href="http://www.southsidedeli.com/">Southside Deli</a></li>
<li class="leaf"><a href="https://stannscommunity.com/the-greens/" title="">St. Ann&#039;s Community at the Greens</a></li>
<li class="leaf"><a href="https://www.facebook.com/pages/Stella-Collision-Serv-Inc/163791313638569" title="">Stella Collision</a></li>
<li class="leaf"><a href="https://www.homesnap.com/Sunny-Rathod" title="">Sunny Rathod - Keller Williams</a></li>
<li class="leaf"><a href="https://www.facebook.com/SweetBettysIceCream" title="">Sweet Betty&#039;s</a></li>
<li class="leaf"><a href="http://www.tfbrowns.com/">T.F. Brown&#039;s</a></li>
<li class="leaf"><a href="https://www.facebook.com/Terancecranstonconstruction" title="">Terance Cranston Construction</a></li>
<li class="leaf"><a href="http://www.smhawley.com/">The Insurance Center</a></li>
<li class="leaf"><a href="http://www.redosier.com" title="">The Red Osier Landmark Restaurant, Stafford</a></li>
<li class="leaf"><a href="http://www.thompsonmotorsllc.com" title="">Thompson Motors</a></li>
<li class="leaf"><a href="https://www.tompkinsins.com" title="">Tompkins Insurance Agencies</a></li>
<li class="leaf"><a href="http://toyotaofbatavia.calls.net/?utm_source=google&amp;utm_content=ZRgptxKl&amp;utm_medium=cpc&amp;utm_campaign=PaidSearch&amp;siteid=SEM_GNY10_google_paidsearch&amp;utm_term=toyota+of+batavia+ny" title="">Toyota of Batavia</a></li>
<li class="leaf"><a href="https://www.facebook.com/Tri-County-Welding-Inc-100821968795459" title="">Tri-County Welding</a></li>
<li class="leaf"><a href="http://www.turnbullhvacr.net" title="">Turnbull Heating, Air Conditioning &amp; Refrigeration</a></li>
<li class="leaf"><a href="http://www.vallejewelersbatavia.com" title="">Valle Jewelers</a></li>
<li class="leaf"><a href="https://www.facebook.com/VieleConstruction" title="">Viele Construction &amp; Development</a></li>
<li class="leaf"><a href="https://weedross.com" title="">Weed Ross Insurance Group</a></li>
<li class="leaf"><a href="https://www.facebook.com/pages/West-Main-Wine-and-Spirits/208995262447108">West Main Wine &amp; Spirits</a></li>
<li class="leaf"><span class="nolink" tabindex="0">Western Regional Off Track</span></li>
<li class="leaf"><a href="http://www.williamkentinc.com/">William Kent, Inc.</a></li>
<li class="leaf"><a href="http://www.glowymca.org" title="">YMCA</a></li>
<li class="leaf"><a href="https://www.facebook.com/TheYngodessShop">Yngodess Shop</a></li>
<li class="last leaf"><a href="https://www.facebook.com/Yume-Asian-Bistro-241123629393541/?fref=ts" title="">Yume Asian Bistro</a></li>
</ul> </div>
</div>
</div>
<div class="panel-panel page-col">
<div class="inside"><div class="panel-pane pane-ad pane-1244 broadstreet-ad broadstreet-1244">
<script type="text/javascript">if (typeof broadstreet !== 'undefined') broadstreet.zone(1244);</script>
</div>
<div class="panel-pane pane-page-title">
<h1></h1>
</div>
<div class="panel-pane pane-page-content">
<div class="panel-pane pane-node-created">
May 18, 2022 - 3:50pm </div>
<div class="panel-pane pane-node-title">
<h1>Developer plans massive warehouse for retail overstock in Batavia business park</h1>
</div>
<div class="panel-pane pane-node-submission">
posted by <span class="username">Howard B. Owens</span> in <a href="/tags/mega-properties">Mega Properties</a>, <a href="/batavia">batavia</a>, <a href="/tags/news">news</a>, <a href="/tags/gateway-ii">Gateway II</a>. </div>
<div class="panel-pane pane-entity-field pane-node-body">
<div class="field field--name-body field--type-text-with-summary field--label-hidden"><div class="field__items"><div class="field__item even"><p><img alt="lucasbushenplanning2022.jpg" src="/files/users/60/2022-05/lucasbushenplanning2022.jpg" style="height:240px; width:460px" /></p>
<p>Mega Properties is planning another massive warehouse for the Gateway II industrial park east of Route 98 in the Town of Batavia.</p>
<p>This time it will be a 200,000 square-foot warehouse available for area retailers to store inventory overstock.</p>
<p>Lucas Bushen, with Marathon Engineering, presented initial plans to the town planning board on Tuesday.  </p>
<p>He said there will be few employees at the warehouse at any one time, so only about 20 parking spaces will be needed.</p>
<p>A full environmental review is required for the building, and the planning board approved a resolution to be the lead agency on the review.</p>
<p>The 22-acre parcel is off of Call Parkway. It will be a <a href="https://www.commercialloandirect.com/definition/butler-type-building#:~:text=Noun,or%20wood%20pole%20barn%20construction." target="_blank">Butler Building</a> with typical remanufactured metal building elements: concrete foundation, metal siding, and sloped roof. </p>
<p>The building will be constructed in phases with Phase One including 71,000 square feet of warehouse space and 3,200 square feet of office space.</p>
<p>There are two ponds on the property. In order to construct the building, one of the ponds will be relocated. There are also two federally designated wetlands on the property.  The wetlands will not be disturbed.</p>
<p>Mega Properties intends to invest more than $3 million into the project.</p>
<p>Mega Properties has long-standing ties to Batavia, having launched in Batavia’s Harvester Business Incubation Center more than 30 years ago. The business is currently based at the Gateway I Corporate Park in the Town of Batavia.</p>
<p>In 2020, just prior to the start of the pandemic, <a href="https://www.thebatavian.com/howard-b-owens/gateway-ii-warehouse-project-seeks-assistance-from-gcedc/551067" target="_blank">Mega Properties sought financial assistance from GCEDC for the project</a>.  At the time, they were seeking approximately $558,497 in assistance, including a property tax exemption of $400,497, a sales tax exemption of $128,000, and a mortgage tax exemption of $30,000.</p>
<p>There was a public hearing on the request but the application did not go any further because of the disruption of the pandemic.  No announcement has been made yet on when the GCEDC board will next take up the application.</p>
<p><em>Top photo: Lucas Bushen presents plans for a warehouse off of Call Parkway in the Town of Batavia to the town's planning board. Photo by Howard Owens.  Below, drawings of the project from planning documents.</em></p>
<p><img alt="conceptialwarehousemega2022.jpg" src="/files/users/60/2022-05/conceptialwarehousemega2022.jpg" style="height:347px; width:460px" /></p>
<p><img alt="conceptialwarehousemega20222.jpg" src="/files/users/60/2022-05/conceptialwarehousemega20222.jpg" style="height:312px; width:460px" /></p>
</div></div></div> </div>
<div class="panel-pane pane-social-share">
<a href="https://www.facebook.com/sharer/sharer.php?u=https://www.thebatavian.com/howard-b-owens/developer-plans-massive-warehouse-for-retail-overstock-in-batavia-business-park" target="_blank" class="share-facebook" title="Share this page on Facebook" data-url="https://www.thebatavian.com/howard-b-owens/developer-plans-massive-warehouse-for-retail-overstock-in-batavia-business-park"><img src="/sites/all/themes/omega_batavian/images/facebook.png" alt="Share this page on Facebook" />Recommend</a><a href="https://twitter.com/intent/tweet/?text=Developer+plans+massive+warehouse+for+retail+overstock+in+Batavia+business+park&url=https://www.thebatavian.com/howard-b-owens/developer-plans-massive-warehouse-for-retail-overstock-in-batavia-business-park&via=thebatavian" target="_blank" class="share-twitter" title="Share this page on Twitter"><img src="/sites/all/themes/omega_batavian/images/twitter.png" alt="Share this page on Twitter" />Tweet</a><a href="https://pinterest.com/pin/create/button/?url=https://www.thebatavian.com/howard-b-owens/developer-plans-massive-warehouse-for-retail-overstock-in-batavia-business-park&media=https://www.thebatavian.com/files/users/60/2022-05/lucasbushenplanning2022.jpg&description=" target="_blank" class="share-pinterest" title="Share this page on Pinterest"><img src="/sites/all/themes/omega_batavian/images/pinterest.png" alt="Share this page on Pinterest" />Pin it</a> </div>
<div class="panel-pane pane-node-comment-form">
<h2 class="pane-title">Post new comment</h2>
<a href="/user/login?destination=node/605553%23comment-form">Log in</a> or <a href="/user/register?destination=node/605553%23comment-form">register</a> to post comments </div>
</div>
</div>
</div>
<div class="panel-panel page-col-last">
<div class="inside"><div class="panel-pane pane-ad pane-1945 broadstreet-ad broadstreet-1945">
<script type="text/javascript">if (typeof broadstreet !== 'undefined') broadstreet.zone(1945);</script>
</div>
<div class="panel-pane pane-ad pane-82176 broadstreet-ad broadstreet-82176">
<script type="text/javascript">if (typeof broadstreet !== 'undefined') broadstreet.zone(82176);</script>
</div>
<div class="panel-pane pane-ad pane-1258 broadstreet-ad broadstreet-1258">
<script type="text/javascript">if (typeof broadstreet !== 'undefined') broadstreet.zone(1258);</script>
</div>
<div class="panel-pane pane-block pane-broadstreet-ads-1949">
<script type="text/javascript">if (typeof broadstreet !== 'undefined') broadstreet.zone(1949);</script>
</div>
<div class="panel-pane pane-block pane-block-241">
<div data-cswidget="10587"> </div>
<script type="text/javascript" async defer src="//cdn.cityspark.com/wid/get.js"> </script>
</div>
<div class="panel-pane pane-ad pane-1257 broadstreet-ad broadstreet-1257">
<script type="text/javascript">if (typeof broadstreet !== 'undefined') broadstreet.zone(1257);</script>
</div>
<div class="panel-pane pane-ad pane-40855 broadstreet-ad broadstreet-40855">
<script type="text/javascript">if (typeof broadstreet !== 'undefined') broadstreet.zone(40855);</script>
</div>
<div class="panel-pane pane-ad pane-1262 broadstreet-ad broadstreet-1262">
<script type="text/javascript">if (typeof broadstreet !== 'undefined') broadstreet.zone(1262);</script>
</div>
<div class="panel-pane pane-ad pane-1251 broadstreet-ad broadstreet-1251">
<script type="text/javascript">if (typeof broadstreet !== 'undefined') broadstreet.zone(1251);</script>
</div>
<div class="panel-pane pane-ad pane-1256 broadstreet-ad broadstreet-1256">
<script type="text/javascript">if (typeof broadstreet !== 'undefined') broadstreet.zone(1256);</script>
</div>
<div class="panel-pane pane-ad pane-1245 broadstreet-ad broadstreet-1245">
<script type="text/javascript">if (typeof broadstreet !== 'undefined') broadstreet.zone(1245);</script>
</div>
<div class="panel-pane pane-ad pane-1249 broadstreet-ad broadstreet-1249">
<script type="text/javascript">if (typeof broadstreet !== 'undefined') broadstreet.zone(1249);</script>
</div>
</div>
</div>
</div>
</div>
<div class="panel-panel panel-col-page-suffix clearfix">
<div class="inside"><div class="panel-pane pane-custom pane-2">
<p>Copyright © 2008-2022 <a href="http://thebatavian.com/" title="TheBatavian.com">The Batavian</a>. All Rights Reserved. <a href="http://thebatavian.com/privacy-policy">Privacy Policy</a> | <a href="http://thebatavian.com/terms-of-service">Terms of Service</a><br />
 </p>
</div>
<div class="panel-pane pane-custom pane-3">
<p><a href="http://authenticallylocal.com"><img alt="blue button" src="https://static.tumblr.com/neq6kdr/SpUll1zvv/authenticallylocal_logo_red_web.png" /></a></p> </div>
<div class="panel-pane pane-custom pane-4">
<p><a href="https://www.newsbreak.com/channels/the-batavian-1592141"><img alt="News Break" src="/sites/all/themes/omega_batavian/images/News Break logo official for web white.png" width="300" /></a></p>
</div>
</div>
</div>
</div>
<script type="text/javascript" src="/files/advagg_js/js___F8KGWIiHdQfl5bO6Dui8ksNE0NZVOw6z7uq1-lDB4k__tkY0XGqphgKxrpfoJ5XLMot4uI1j7Q6RUQjt3Ugx2Uc__ZE1YzrmRrq78kDV5aH_1eaOISSctoCO7FJtBucbLSKE.js"></script>
<script>
adthrive.cmd.push(function () {
  // Disable if the URL matches the pattern.
  adthrive.disableAds(['/sponsored-post']);
});
</script>
</body>
</html>
